cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
978 Views
Message 11 of 16

Re: Fibre 900 FTTP PPPoE set up with MikroTik

@evansnp would you mind confirming what actions you had to take to get bt IPTV working as I have a BT sport pro box which isn't connecting

0 Ratings
968 Views
Message 12 of 16

Re: Fibre 900 FTTP PPPoE set up with MikroTik

Is there an option to enable IGMP snooping?  If there is, do so.

0 Ratings
950 Views
Message 13 of 16

Re: Fibre 900 FTTP PPPoE set up with MikroTik

Hi @mvnick , I notice that the link that I posted earlier is no longer available.  I'll try and go through my notes and get back to you. Basically, you need to install the multicast module (which isn't available yet in 7.x firmware), give your ingress Ethernet port (ETH1 in my case) an IP address outside of your normal range, set this as an upstream rendezvous point.  I'll update when I get a chance to go through my router config.

936 Views
Message 14 of 16

Re: Fibre 900 FTTP PPPoE set up with MikroTik

@evansnp Thanks. I have the Mikrotik router with port 5 connected to a vdsl modem and pppoe then connecting to the internet. Port 1 is connected to the switch and the Bt to box connected to port 4 ( that is in a bridge with ports 1 2 and 3.

ihave added the multicast package and configured ether5 in the gimp settings as an uplink interface ( is that correct or should it be the pppoe connection that goes over ether5?

 

also added the bridge in ( wasn’t sure whether to add this or ether2 which the Bt box is connected to. The bt box is on the network and can stream on iPlayer but anything bt based ie the streams fail. 

0 Ratings
931 Views
Message 15 of 16

Re: Fibre 900 FTTP PPPoE set up with MikroTik

There is on the bridge interface. I have ether1 connected to the switch but ether 1 - ether4 are in a bridge. I have now connected the bt box directly to ether4 so yes I can enable igmp snooping on the bridge interface.

0 Ratings
921 Views
Message 16 of 16

Re: Fibre 900 FTTP PPPoE set up with MikroTik

Hi @mvnick You need to configure the firewall to allow the traffic too.  This is from my FW:-

add action=accept chain=input comment="Accept IGMP traffic" protocol=igmp
add action=accept chain=input comment="Accept Multicast traffic" dst-address=\
    234.81.0.0/16
add action=accept chain=forward comment="Multicast Forward rule" dst-address=\
    234.81.0.0/16 out-interface=bridge-net20

Note: bridge-net20 is the 'bridge group' where my BT box is connected (which I no longer have)

I'll post more as I find it.

0 Ratings