Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 8

SmartHub2 - Folder and File Sharing

I know that this has been discussed before, and I have tried to piece together the various points, but I must be still doing something wrong. I had this working on a much earlier version of BT HomeHub many years ago, but I cannot get it to work now.

What I have done, (using a PC running Linux - in case it makes a difference?):

1.) Formatted a 32GB Sandisk Extreme USB3 flash drive as NTFS. (I know SH2 port is only USB2).

2.) Created a folder on the drive called "Music"

3.) Made the drive shared in Properties

4.) Copied some folders of music files into the "Music" folder.

5.) Made the "Music" folder and sub-folders shared with Guest access.

6.) Plugged the USB drive into the SmartHub2 and verified in Home > Advanced Settings > My Network that the SH2 can see the USB drive.

7.) On the PC, gone to\usb1 - but not able to connect to the USB drive.

What am I doing wrong? Should I format the drive as something other than NTFS?

Is it that I am trying to do this under Linux that is the problem? Do I need to try to get access to a Windows PC? Or am I just doing the right things in the wrong order?

I don't think that the SH2's USB port is designed to supply much power to a peripheral, but a flash drive doesn't need much does it?

Any suggestions please?


0 Ratings
Message 2 of 8

Re: SmartHub2 - Folder and File Sharing

The usb port on the hub uses smb1, it is possible that you will need to install the relevant package on your Linux machine. Smb1 is disabled by default on Windows machines as it is deprecated and needs to be re-enabled.

0 Ratings
Message 3 of 8

Re: SmartHub2 - Folder and File Sharing


Thanks - I've been able to borrow a Windows 10 PC that had Samba 1 enabled and I can see the USB stick shared over the network. So, the server side is OK, it is the Linux client that was preventing access.

Does anyone here know how to enable Samba 1 client in Linux? Specifically Linux Mint 20.2. The response to "smbclient --version" is: "Version 4.11.6-Ubuntu" I will also ask this question over on the Linux Mint Forums.

If I can get this working, (clients), I would like to use a larger storage drive on the SH2. As I noted in my OP, I am aware that the hub can supply limited power from its USB port - but does anyone know how much current it can supply? I have a few 2.5" drives that I could use, from a 160GB that needs 0.451A to a 2TB requiring 0.85A @ 5 volts. I would rather not use an externally powered drive if at all possible.

0 Ratings
Message 4 of 8

Re: SmartHub2 - Folder and File Sharing

I did have a quick Google, but didn't know which flavour of Linux you were running, might be a help.

I run an unpowered Toshiba 3Tb drive on the hub usb port that allegedly requires 1.0A@5V so you should be ok.

0 Ratings
Message 5 of 8

Re: SmartHub2 - Folder and File Sharing


Thanks. I am using Linux Mint 20.2 which is derived from Ubuntu. I did try a search before posting on here, but that page didn't come up. Unfortunately, it only enables Samba 1 on a server - not client - so didn't work for me, (I did try!).

I have also posted on the Linux Mint forums about Samba 1 client, so hopefully someone will come back to me - but does anyone else on here have any more ideas?

Re un-powered drives: glad to hear that at least 1 amp is available from the USB port! Normally I would just "try it and see", but didn't want to risk breaking the Smart Hub.

0 Ratings
Message 6 of 8

Re: SmartHub2 - Folder and File Sharing

Unfortunately, I have now discovered that other "Clients", (such as Smart TVs), that I had intended to use with this are also unable to recognise Samba 1 - so I'm not going to pursue that method. I'm now looking at whether my old RaspberryPi is up to running as a server.

0 Ratings
Message 7 of 8

Re: SmartHub2 - Folder and File Sharing

0 Ratings
Message 8 of 8

Re: SmartHub2 - Folder and File Sharing


Thanks for the link. The only RaspberryPi's that I have available are a 1B, (not sure if there is even an up-to-date OS available for that now?), and a 3B. I installed OpenMediaVault on the 3B, but had issues trying to mount the, (separately powered), 4TB hard drive - so have parked that project, for now at least!

I hope to re-visit it again when the cold winter nights draw in, and I have more time 😀

0 Ratings