cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
samhubbard
Beginner
159 Views
Message 1 of 3

Smart Hub 2: Spaces disallowed in WPA2 password (BUG)

Hi, I've got a Smart Hub 2 set up with a WPA2 password, which has been in place about 1.5 years. Recently I needed to temporarily turn off 5GHz in order to set up a smart home device, and discovered that the "Home>Advanced settings>Advanced wireless" form would not submit, because my WPA2 password contains spaces. This is despite having not changed the password. The exact error message on submitting is this:

"Disallowed characters in the security password

Your security password contains the following disallowed characters:

Only ASCII values between 32 and 126 are allowed.
Please check your security password and try again."

This is a bug: the space character has ASCII value 32, so according to the error message it should in fact be accepted. It is extremely frustrating as it is essentially locking me out of changing the wireless settings unless I also change my WPA2 password—which I don't want to do because I have embedded devices in my house which have the password hardcoded. I believe the issue has been caused by a firmware update on the Smart Hub, but I was wondering if anyone knew of any workaround to get past this error.

Failing this, does anyone know the proper route for reporting this bug so it can be fixed in a future update. My current firmware version is v0.24.04.11017-BT, and it was updated on January 5 2021. My GUI version is 1.71 05_06_2020.

0 Ratings
Reply
2 REPLIES 2
NeilO
Moderator
Moderator
118 Views
Message 2 of 3

Re: Smart Hub 2: Spaces disallowed in WPA2 password (BUG)

Hi @samhubbard, welcome to the community and thanks for posting, I'm sorry to see you've had trouble with setting Hub your password. I raised this with the Hub team who confirmed with the current firmware a space is not allowed in the WPA2 password.

This was possible on previous firmware options but by design, you won't be able to have a space on the current firmware,  I'm sorry for any inconvenience caused as I appreciate the hassle this will cause changing it on all your devices. 

They've also explained there's a bug with the pop-up message, “ASCII values 32 and 126” is incorrect as it should be stating 33 and 126 (i.e. space is not allowed). A case has been raised to get the error message corrected.

Thanks

Neil

0 Ratings
Reply
Pedigree500
Contributor
96 Views
Message 3 of 3

Re: Smart Hub 2: Spaces disallowed in WPA2 password (BUG)


@NeilOwrote:

This was possible on previous firmware options but by design, you won't be able to have a space on the current firmware,


Interesting. What rationale did the "Hub team" offer for disallowing space characters?

0 Ratings
Reply