cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
7,187 Views
Message 1 of 27

Smart hub 2 and assigned IP address not working

Hi all

I have had a smart hub 2 for a couple of years or more and when I first got the router I set up all my devices to a  static ip.  

I would do this at the hardware first if possible  but some devices could not be changed at hardware level and what i used to do is go into the router settings and change the devices ip and select use this ip for this device and save it.  No problems. 

now jump to now I have added a new device and it got its own IP address from the routers own pool range something like .175.  I went into the routers setting selected the device and change the name and icon and ip to .40 and use this ip all the time option and saved it.

 The only  thing it has saved is the  name and icon but not the ip and  use this ip all the time option. 

for the hell of me I can. It get this router to change devices ips to a number I want to use. I was able to do this with ease a couple years back as I have a lot of devices already saved but now I can not do this.  

I also noticed the settings page has changed and noticed the router must of had a firmware update. Is there a bug in this ip save option as I have a few devices now I can not assign a ip In this router anymore.  

also I am using whole Wi-Fi discs for the Wi-Fi and have turned Wi-Fi off on the hub  but that should Not matter. 

I need help asap as I need static devices to talk to them using other network devices on the same network and if they keep moving it’s making them impossible to do what I need.  

any help thanks.

0 Ratings
Reply
26 REPLIES 26
7,173 Views
Message 2 of 27

Re: Smart hub 2 and assigned IP address not working

As address reservation still uses DHCP to allocate the address (albeit the same each time), you will need to select an address within the DHCP range of the hub. You can change the DHCP range of the hub if this assists.

 

0 Ratings
Reply
7,144 Views
Message 3 of 27

Re: Smart hub 2 and assigned IP address not working

I have looked at my ipv4 range and its 64 to 253 default, I am trying to use 37 all my other devices are from 20 to 36 which i have set using the routers ip address and always use this ip address to on.

 

so if i was able to do that in the past why can i not do this now, also i thought you never use an address within the allocated server address as the hub would always auto assign them in that range and a user if wanting a static ip would use a outside number which i have done in the past as most of my devices are 20 to 36 which are outside that range.

 

if i change the device which uses 73 to 74 the next ip address which is withing that DHCP and hit save it still does not change.

 

 

 

thanks

0 Ratings
Reply
7,125 Views
Message 4 of 27

Re: Smart hub 2 and assigned IP address not working

You are confusing static addresses with address reservation. A static address by definition can only be applied on a device itself. Any device obtaining an address from a router must again by definition be using DHCP.

If the hub DHCP range is 63-253 then I would have thought it can only issue and reserve those addresses. It is possible that in a previous version of firmware it was possible to allocate a reserved DHCP address outside of the normal DHCP range but perhaps not now possible.

I'm only guessing at the cause of your problem but that seems the likely possibility

 

 

0 Ratings
Reply
7,110 Views
Message 5 of 27

Re: Smart hub 2 and assigned IP address not working

@meridius 

As already pointed out, you are trying to reserve an address which is not in the DHCP pool and that just won't work no matter how much you insist that it should.

If you wish to reserve 192.168.1.37 then you can only do it be extending the range of the DHCP pool to include that address.

To do this go to Advanced Settings/My Network, click the IPV4 tab and change 192.168.1.64 to 192.168.1.37 and then reserve it.

0 Ratings
Reply
7,079 Views
Message 6 of 27

Re: Smart hub 2 and assigned IP address not working

Ok so my router has A reserve of 192.168.1.64 to 192.168.1.253 which is the default 

a device that I have is using a IP address of 192.168.1.173 and I changed it to 192.168.1.174 and I save it, it does not change still says on .173

if I try and change it 192.168.1.37 and save it, it does not change and stays on .173

so I tried two ip numbers one within the reserve address and one outside of it and I can not save it and reserve that ip address in the router for that device.  I can not set a static ip on the device itself as you can not do that. 

I just don’t know how to get my new device to use a IP address I want it to stay on even buy using a IP address within the reserve like you all suggested. Like I say never had this problem a couple years back when I changed devices to what IP address I wanted within the router. 

alao in the router you click in the IP address and u can change it and save it but it just does not change. I have tried a few IP address within the default address of the DHCP Pool and still can not be altered and saved. 


I could change the pool from .64 - 253 to .10 - 253 but what’s the point if I can not even change the devices IP address from .173 to .174 which is the next IP address within the DHCP pool and save it 

 

is it because the device is still plugged in do need to unplug it to release the IP address ?

 

also another question why has but set the pool start from .64 and not say .10 why have they missed of .02 to .64 is this for people who can set static IP address on the hardware itself as this is outside the DHCP pool 

 

thanks 

 

0 Ratings
Reply
7,060 Views
Message 7 of 27

Re: Smart hub 2 and assigned IP address not working

That sounds like a device issue. If it's a Windows device then try the following.

Bearing in mind that the hub manager on the SH2 is a bit flaky to say the least

  • If the device is powered up then shut it down (don't put it to sleep or hibernate it, shut it down)
  • Extend the DHCP pool on the hub to include the address you want to reserve
  • Using another device; On the hub, from Advanced Settings- My Network, manually change the IP address in the text field and set Always use this IP Address to YES (the chances are that the hub manager will show it as still connected even though you've shut it down)_
  • Restart the device 
  • Open a command prompt and type ipconfig /release (including the space)
  • In the same command prompt type ipconfig /renew
  • Still in the same command prompt type ipconfig /all
  • search down the list that is displayed for the adapter you are using and check its IPv4 address is as you set it
0 Ratings
Reply
7,030 Views
Message 8 of 27

Re: Smart hub 2 and assigned IP address not working

Hello

 

thanks but that did not work it just will not save the ip address i pick for that address for that device.

 

on searching this seems to be a new bug that has been going on for a couple of years, that's just great as BT dont seem to want to fix this and now i can not give some of my devices a static p

Manually assigning IP addresses on Smart Hub 2 - BT Community

 

i am not sure what to do next, this is crazy as i have a smart hub 2 and 3 whole wifi discs all connected and i cannot give my devices a static ip i want.

 

 

 

 

 

 

0 Ratings
Reply
7,019 Views
Message 9 of 27

Re: Smart hub 2 and assigned IP address not working

What type of device is it?

0 Ratings
Reply
6,995 Views
Message 10 of 27

Re: Smart hub 2 and assigned IP address not working

@meridius 

What's wrong with doing the IP assignment in the devices themselves if it's so important that they have specific IP Addresses.

When any router assigns an IP address to a device it gives it a lease time and potentially the device retains that address until the lease runs out , typically 24 hours, at which time it would pick up the new address. Is that why you're not seeing your changes applied as you would like?

0 Ratings
Reply