Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 2

BT Sport App - No chromecast symbol on Kindle Fire HD 8 10th Gen


I'm trying to get the BT sport app  (Running on Kindle Fire HD 😎 to cast to the TV using a chromecast (First Gen), the BT sport app works fine but doesn't show the cast icon in the corner as it has on other devices in the past.

I've tried

  • Uninstalling and reinstalling BT sport app and logging in and out
  • Rebooting and hard resetting the chromecast 

Both are on the same network and as an example the iplayer app casts fine from the same tablet to the chromecast so I know they do work together. In fact BT sport has worked with casting too on a previous tablet.

Hoping someone can point me in the right direction, seem to be going in circles with it!

0 Ratings
Message 2 of 2

Re: BT Sport App - No chromecast symbol on Kindle Fire HD 8 10th Gen

BT Sport is not supported on Amazon tablet devices.  Even if it were, casting from the app on an Amazon device isn't supported as it requires Google Play Services which Amazon devices don't have.

The fact that you've managed to install the app suggests you've either side-loaded it, or you've side-loaded Google Play Store onto your device and installed from there.  Neither of these methods are supported.