Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 5

ONT Mismatch on Address with Openreach


Can anybody help me with this as the situation is getting a bit desperate now! 

I ordered BT Fibre through BT back in December and the order was repeatedly rejected by Openreach. After many calls this was escalated to Openreach and they have still not fixed it. 

I have just moved into a new build house and it turns out that the reason for my order being rejected was there appeared to be an active line at the address. I sent a picture of the ONT serial number to BT and they confirmed that the serial number on the ONT did not match my address, hence Openreach reported that the line was already active. 

It's now nearly the end of January and I still cannot get Fibre activated as I am waiting on a response from Openreach who are being incredibly slow. Please help! 

Tags (3)
0 Ratings
Message 2 of 5

Re: ONT Mismatch on Address with Openreach

I gave in an joined Virgin in the end. Havent had a problem since.

0 Ratings
Message 3 of 5

Re: ONT Mismatch on Address with Openreach

I tried Sky and Virgin back in November and they ran into exactly the same problem. The reason I moved to BT is they were able to at least tell me what the problem was, Sky and Virgin could not.
0 Ratings
Message 4 of 5

Re: ONT Mismatch on Address with Openreach

did you try speaking with BT FTTP TEAM 08005874787 and see if they can help you

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
Message 5 of 5

Re: ONT Mismatch on Address with Openreach

Hi imJolly thanks for your response. No not yet I will try them. Oddly enough a BT Openreach engineer just turned up, took a picture of my ONT box and cleared off again. As we live in a new build development I've also just heard that the plot numbers of the houses changed mid-development so I think this might be what this issue is. Still waiting for a fix though!
0 Ratings