cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
497 Views
Message 1 of 4

BT TV Box Pro missing several channels

Go to solution

Hi. New here. My BT TV Box Pro has been no problem for over a year. Just moved house to a different area of UK. I had brand new co-ax installed today. I can get BBC1, ITV1, and a few others on Freeview if I connect the aerial directly to my smart TV. I can also get them if I connect the Box Pro as a "pass through". However, the moment I try to see these ( and a few others) on the Box Pro, or view them in the guide, I can't see them & get "no info". On signal strength, I have 100% on those channels I do get eg BBC2, Ch4, Ch5... but on BBC1 & ITV1 I get "undefined%". I've retuned numerous times. There doesn't appear to be a place to select the area/ postcode from which I'm viewing (DN33). Am I missing something, doing something wrong, just stupid, or is it to do with the EE changeover... mine has gone from purple lights to blue & now nearer green. TIA for assistance.

0 Ratings
Reply
3 REPLIES 3
489 Views
Message 2 of 4

Re: BT TV Box Pro missing several channels

Go to solution

There have been a few previous reports of the Pro Box not liking too strong a signal. Usual recommendation is a variable attenuator from Amazon. Just make sure you get one with co-ax & not F connectors.

0 Ratings
Reply
410 Views
Message 3 of 4

Re: BT TV Box Pro missing several channels

Go to solution

Many thanks. I ordered an attenuator. However, I tried a full factory reset, though I didn't really want to lose all my recordings, and that fixed the issue.

0 Ratings
Reply
365 Views
Message 4 of 4

Re: BT TV Box Pro missing several channels

Go to solution

Hi @JPS130 ,

Thanks for letting us know the factory reset fixed this but personally I would go with the attenuator also.

Cheers

David

0 Ratings
Reply