cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
2,386 Views
Message 1 of 10

Apple devices not being assigned IP address by DHCP on HH5

Go to solution

I am having issues with my network and hopefully someone can help. I set the network up 5 years ago and haven't had any problems until a few weeks ago.

First problem was my ipad would not get an ip address - it was assigning itself a 169 address. I dont know how but after a week that fixed itself. Then today the same thing happened to my iphone 12 - no IP address assigned so it is giving itself a 169 address. After the problem started today I turned off private wifi and limit IP address tracking on the iphone but that didn't help.

Setup is as follows: HH5 with 2.4&5GHz turned off, all other settings standard (no BT access control in place). Three TP Link EAPs connected (cat5) to HH5. All EAPs use the same SSID on 2.4GHz. EAPs set to use channels 1/6/11.

I havent changed anything for 5yrs but all of a sudden I am having problems and can't work out why. Thank you for any help you can offer.

0 Ratings
Reply
9 REPLIES 9
2,365 Views
Message 2 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

@wagonface 

Welcome to this user forum for BT Retail phone and broadband customers.

If your devices have been using randomised MAC addresses (Private addressing), then the home hub has probably run out of IP allocations, as each MAC address is allocated a new IP address.

The only way to reset the DHCP table, is by factory resetting the HH5.

Its best not to use private addressing on your own home hub SSID, otherwise you will eventually run into the same problem again.

 

0 Ratings
Reply
2,343 Views
Message 3 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

Thank you @Keith_Beddoe  that is very helpful. The apple private setting is for all networks so I will change my family devices for my network, but guests will always have it on and I guess will end up taking up all my IP addresses.

2 stupid questions before I factory reset the hub:

1) I have an NAS attached and did some custom settings when I bought it 7yrs ago (static IP address outside DHCP range, port forwarding). If I back up current hub settings and then restore them after factory reset will that still be okay with the DHCP table? Or will it restore the DHCP table?

2) can I not just set the lease time to 5mins (currently 21 days), will that not free up an IP address for my phone?

Thank you again for helping.

0 Ratings
Reply
2,335 Views
Message 4 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

Unfortunately a user backup also retains the DHCP assignments as they are stored in the user.ini file (encrypted). Restoring the backup is going to restore those values, as for some reason BT decided to keep them in non-volatile memory (flash), instead of system memory, possibly to keep the cost down.

This is a major issue which seems to affect all of the earlier home hub versions. Not sure about the Smart Hub 2, but I doubt the core coding has change much, as it used a lot of freely available code.

Static IP addresses outside of the DHCP range would have been set on each device, so would not be affected by a factory reset.

Port forwarding rules would have to be re-entered.

As far as DHCP lease times, I think you will find that reducing them would not affect existing leases, and may not even affect new devices, as I think that was/is still a "feature/bug" in the home hub core firmware.

The result is that eventually there are no spare IP addresses.

 

0 Ratings
Reply
2,330 Views
Message 5 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

As long as you didn't change the DHCP range (.64 on IIRC) then the NAS should be fine, ie it should currently have an address below .64.

You could also try setting static IP addresses below .64 on the Apple devices too, as that should take DHCP out of the equation for them, if indeed that is the issue.

0 Ratings
Reply
2,244 Views
Message 6 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

Thank you. I tried to set up a static IP addres on my ipad using the settings in the screenshot, but it will not connect to the router. No idea why. I only have one other static device and I know the IP address of that and chose a different one for the ipad. Am I doing something wrong?ipad ip.jpg

0 Ratings
Reply
2,238 Views
Message 7 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

@wagonface 

As you are using a manually assigned static IP address, you will also need to manually configure the DNS settings as well. You can use 192.168.1.254 or another public DNS server.

Also the home hub cannot assign an IP address which is outside of the DHCP scope.

2,230 Views
Message 8 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

@Keith_Beddoe  thank you - it works now!

If I move some devices onto static IP addreses which are outside of the dhcp range (eg use .25) will that free up the IP address that the ipad was using (eg .150) so it can be used by something else? Or is that IP .150 reserved for the ipad forever?

0 Ratings
Reply
2,226 Views
Message 9 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

Unfortunately the home hubs never seem to "forget" DHCP assignments, so the DHCP table eventually fills up and the only way to clear it out, is with a factory reset of the home hub, otherwise devices fail to get an Internet connection.

Any device that uses MAC randomisation (private addressing) , will eventfully fill up the DHCP table. Its best to turn that off when connected to your home hub.

2,216 Views
Message 10 of 10

Re: Apple devices not being assigned IP address by DHCP on HH5

Go to solution

@wagonface 

Apologies, I'd forgotten about that particular Apple quirk. If you set a static IP in Windows, you are forced to enter DNS. But as @Keith_Beddoe pointed out, IOS will happily leave it as automatic despite that not working.

0 Ratings
Reply