cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
668 Views
Message 1 of 8

BT Https certificate and Windows 11

I am using Window 11 version 23H2.I have FFTP broadband supplied by BT, due to not having a static IP address I have been using https://www.noip.com/ to allow me to connect and view my IP webcam. When I use an open port checker  https://www.yougetsignal.com/tools/open-ports/ this confirms that the port concerned is open. This allowed me to view my webcam via the internet from anywhere, this worked OK until recently. When I now use the noip link, I end up at my BT router home page and do not now connect to my webcam:

JimCos_0-1704389634691.jpeg

 

I can connect and view my webcam using my mobile but not by using any Windows PC’s. I believe that the issue is caused by the BT Certificate which prevents windows allowing me to view my webcam.

JimCos_1-1704389634694.png

 

Any help to resolve this problem would be appreciated.

 

Many thanks.

0 Ratings
Reply
7 REPLIES 7
657 Views
Message 2 of 8

Re: BT Https certificate and Windows 11

@JimCos 

Welcome to this user forum for BT Retail phone and broadband customers.

You would not be able to connect to your external IP address from within your home network, as NAT Loopback is not available on the home hub, so you will simple be redirected back to your home hub.

You would need to access your webcam using its own local LAN IP address, or by using a device connected to a different network, like mobile data.

You can ignore the certificate error when connection to the home hub web interface, as its not a https connection.

 

0 Ratings
Reply
632 Views
Message 3 of 8

Re: BT Https certificate and Windows 11

Hi Keith,

Thank you for your prompt reply, the issue that I have is that I could view my webcam as explaind above without any problems until recently. I suspect that some thing must have changed perhaps in a Windows update that has created the problem of not now being able to view my webcam.

Many thanks,

Jim.

0 Ratings
Reply
626 Views
Message 4 of 8

Re: BT Https certificate and Windows 11

At one point NAT loopback was enabled on the hub, it has probably now been disabled again with a hub update meaning you cannot access your external IP address from within your network.

Can you access the camera by using your mobile on 4G rather than WiFi?

0 Ratings
Reply
625 Views
Message 5 of 8

Re: BT Https certificate and Windows 11

It should be possible to access your external IP from outside the LAN - support for this was added to BT hubs many years ago.
I've just tried accessing your IP address and it shows a FOSCAM IPCam Client page when I use HTTP but fails to connect when I use HTTPS.

You're trying to access over HTTPS (which is why you see the certificate error). Chrome recently updated to automatically try HTTPS before HTTP - I suspect this is why you're seeing this issue now. Try manually changing the address in the address bar to http:// instead of https:// and I suspect it'll work OK.

Note: you're currently running your camera over the internet insecurely. If you access it from an untrusted network, they will be able to read your username and password and access your cameras without your knowledge.  A quick check of the Foscam web site suggests that it should be possible to access your camera over HTTPS instead - it would be wise to map this port on the firewall instead.

606 Views
Message 6 of 8

Re: BT Https certificate and Windows 11

Hi  Licquorice,

Yes, I can access the camera using 4G whith the Wi-Fi switched off.

Jim

0 Ratings
Reply
586 Views
Message 7 of 8

Re: BT Https certificate and Windows 11

Hi DarrenDev,

Thank you for your feedback, I changed the address bar to HTTP and it connected OK.

Any advice on how to change the port on the firewall to HTTPS would be appreciated.

Jim.

0 Ratings
Reply
577 Views
Message 8 of 8

Re: BT Https certificate and Windows 11

Firstly I'd check your camera supports HTTPS - try going to https://your_camera_ip in a browser from your PC.
It'll show a certificate error if it supports HTTPS - accept that and then confirm it works OK for you.

Assuming that works then just edit the firewall rule that you set up - it's currently mapping the external port 80 to your camera port (default 1818 I believe). Just change that to map from external port 443 to internal port 443.

When you access your camera remotely, you will always see a certificate error - that's unavoidable I'm afraid, as the camera will be serving an internally-generated certificate that your browser can't trust.

0 Ratings
Reply