cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
springett
Contributor
1,422 Views
Message 1 of 7

Hybrid Connect not working correctly

Go to solution

Hi guys

I've recently moved house and this morning BT sent me my new Halo3+ package. The Smart Hub 2, the Hybrid Connect box, and a WiFi disc.

I don't have my broadband installed yet but I've been told by multiple people from BT that I can use the Hybrid Connect for a 4G connection until the engineer has been in a few weeks.

After setting up the Smart Hub 2 and pairing the Hybrid Connect to it, the Hybrid doesn't actually stay connected. It works fine for about 2-3 minutes, then the BT logo light in the centre changes from blue to white, and I no longer have an internet connection. The Hybrid Connect section in the Smart Hub manager disappears after the light turns white. 

Restarting the Hybrid restarts the process. All lights light up fine as they should do in the correct order until a solid blue circle light, 2-3 minutes of uptime then back to a white light and no connection.

Not only that, the WiFi disc I've been sent is dead on arrival, it doesn't turn on at all. Slightly disappointing. All this new kit and not one part of it is usable for me 😐

 

Any ideas on what I should be doing to keep the Hybrid connected successfully? I have no idea if this is a problem on my end or if it's a problem with the new kit. I've tried factory resets on both devices multiple times and every time the outcome is still the same.

 

Thanks in advance

0 Ratings
Reply
6 REPLIES 6
NeilO
Moderator
Moderator
1,370 Views
Message 2 of 7

Re: Hybrid Connect not working correctly

Go to solution

Hi @springett I'm sorry to see you experienced problems with your Hybrid Connect service, did you manage to get this sorted? A solid white circle means a firmware update is needed.

Solid white circle

Firmware update required.

Disconnect the Hybrid Connect from the Hub, then perform a Factory Reset on the Hybrid Connect by pressing the pinhole reset button on the back for 15 seconds. Once the circle starts flashing green, connect the Hybrid Connect to the Hub via Ethernet and then leave for 30 minutes to set up.

 

If you still experience problems connecting give us a call on 0800 800 150 and ask to report a fault with your Hybrid connect service and you will be transferred to a specialist team who can help with these types of issues.

Thank

Neil

0 Ratings
Reply
springett
Contributor
1,363 Views
Message 3 of 7

Re: Hybrid Connect not working correctly

Go to solution
I tried the firmware update but it didn't work, possibly because there was no internet connection from either the smart hub as the line hasn't been installed yet, or the hybrid as it wouldn't connect to 4G properly.

After leaving everything plugged in for around 24 hours the Hybrid connected properly on its own and has stayed connected since.

For what it's worth though, this is clearly a problem other people are having as well as I've seen a few posts with the same problem.
0 Ratings
Reply
Martle
Beginner
457 Views
Message 4 of 7

Re: Hybrid Connect not working correctly

Go to solution

Hi did you manage to fix this issue. Am having the same issue i reset the hub via the little pin hole. Also BT sent me out a new 4g hub but still having the same issue.  It's driving me crazy cuz I life the middle of no where and my home Internet isn't reliable I get 4mb download and I have always had issues with it dropping so I realky rely on the 4g hub alot. 

0 Ratings
Reply
springett
Contributor
420 Views
Message 5 of 7

Re: Hybrid Connect not working correctly

Go to solution

Hi, this problem sorted itself out after leaving it connected for a night or two. No idea how but it seemed to fix it and worked fine from then on.

chrisa77
Beginner
140 Views
Message 6 of 7

Re: Hybrid Connect not working correctly

Go to solution

The white light around the BT logo indicates that the 4G Hybrid is updating its firmware. Can take up to 30 minutes.

0 Ratings
Reply
12grgrgr12
Beginner
47 Views
Message 7 of 7

Re: Hybrid Connect not working correctly

Go to solution
Well done with that, mine has been connected for a week and done nothing!
0 Ratings
Reply