cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,038 Views
Message 1 of 11

Hybrid connect

I received my hybrid connect today. 
blue circle lights - which I’ve read means it’s connected to my hub but it has solid red bars. I read to contact technical help which I did and was told this is how it’s meant to be until it is in use. However when I’ve tried troubleshooting it constantly says to contact BT as there is a problem. 
When I go on the app it shows it’s not connected. 
please can anyone help before i Chuck it out the window. 

0 Ratings
Reply
10 REPLIES 10
1,024 Views
Message 2 of 11

Re: Hybrid connect

0 Ratings
Reply
1,001 Views
Message 3 of 11

Re: Hybrid connect

Yep I’ve followed everything on that 

0 Ratings
Reply
948 Views
Message 4 of 11

Re: Hybrid connect


@Lisa21515wrote:

I received my hybrid connect today. 
blue circle lights - which I’ve read means it’s connected to my hub but it has solid red bars. I read to contact technical help which I did and was told this is how it’s meant to be until it is in use. However when I’ve tried troubleshooting it constantly says to contact BT as there is a problem. 
When I go on the app it shows it’s not connected. 
please can anyone help before i Chuck it out the window. 


You’ve probably chucked out of the window by now, but that is not how it’s meant to be.

Steady blue central light is fine. It’s connected to the hub.

Red signal bars are not fine. Flashing red means there is no 4G signal. Solid red means BT need to sort it out unless restarting it gets it working. 

0 Ratings
Reply
935 Views
Message 5 of 11

Re: Hybrid connect

You would think that flashing red means no signal but I have had this problem since  12 December and despite new hybrid unit and new router  the problem still exists. We live in a strong 4g area and my BT mobile shows 80 mbs where the hybrid connect is.

BT say there may be a problem on the line but as I am having FTTP  fitted tomorrow, they say this should fix the problem

0 Ratings
Reply
917 Views
Message 6 of 11

Re: Hybrid connect

Than you for your reply. 
move tried a few times to restart it. I’ve move it around etc. I’m going to try it a few more times then ring them again. 

909 Views
Message 7 of 11

Re: Hybrid connect


@Lisa21515wrote:

Than you for your reply. 
move tried a few times to restart it. I’ve move it around etc. I’m going to try it a few more times then ring them again. 


Just to clarify. Mine has never shown solid red signal bars. I do get flashing red signal bars sometimes when the 4G signal drops, but that’s for EE to fix which they usually do within an hour or so.

Solid red is not how it’s supposed to be. Don’t let them tell you otherwise. It’s supposed to be blue, or white when the hybrid has actually taken over because of a broadband fault.

Hope you get it sorted.🤞

0 Ratings
Reply
897 Views
Message 8 of 11

Re: Hybrid connect

Yeah everywhere I’m reading it’s saying it’s a fault etc. it’s doing my head in now haha when I next speak to them I definitely want it sorting  paying for an extra service that I’m not even getting  

thank you. 

0 Ratings
Reply
886 Views
Message 9 of 11

Re: Hybrid connect

Good luck with speaking to them. I have called 9 times and had to explain the problem I have to 9 different people and it is still to be resolved and still showing red. They have though given me a £30 credit which is start. I just hope the problem is resolved tomorrow when I have FTTP installed. Like you, I don't like paying for a service I cannot use

0 Ratings
Reply
876 Views
Message 10 of 11

Re: Hybrid connect

At least it’s something back which you don’t get often. But surely they should know how to rectify these issues ? 
sorry for being thick but what if FTTP? 

0 Ratings
Reply