cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
475 Views
Message 1 of 4

IPv6 on a Draytek router

Go to solution

This discussion started on the back of a different one, but I felt I should probably open a new thread rather than hijack someone else's question.

FYI, the discussion was this one: https://community.bt.com/t5/Home-setup-Wi-Fi-network/TP-Link-routers-and-IPv6/td-p/2290715

I have a BT Infinity DSL subscription, and I use a Draytek 2865 to connect.
No landline in this house, so no Digital Voice issues.
My IPv4 has no issues at all.

But when I tried to activate IPv6, I got the following:
- In WAN / Internet Settings, IPv6 is set on PPP, with a Ping detect based on Couldflare's servers, and RIPng not enabled
Screenshot 2023-11-29 165749.png

- With this, the router seems to connect to IPv6. It gets an IPv6:

Screenshot 2023-11-29 165611.png
And the router is able to ping Google's ipv6 servers
Screenshot 2023-11-29 200632.png

Problem is that my laptop still gets a ULA address:
Screenshot 2023-11-29 165921.png

The problem seems to be on the LAN side of things...

I've tried with the DHCPv6 server on and off, I've tried all the options of management (SLAAC/DHCPv6/off), I've tries the 0-Bit on and off.

Did one of you get IPv6 working on their Draytek router?
If yes, are they willing to share screen grabs of:
- LAN / General Setup / IPv6
- LAN / General Setup / IPv6 / Advanced Settings (DHCPv6 section)
- LAN / General Setup / IPv6 / Advanced Settings (bottom of the page section)

Thanks!

0 Ratings
Reply
3 REPLIES 3
432 Views
Message 2 of 4

Re: IPv6 on a Draytek router

Go to solution

Finally got there. Solutions were:
- WAN1 was set on PPoA => Moved to PPoE
- WAN1 / Internet Access / IPv6 => Enabled RPIng
- LAN / General Setup => SLAAC & 0-Bit
- DHCPv6 Enabled & Prefix Delegation Disabled
- Advanced Settings: RAC Enabled (Default values) and RPIng enabled

Et voila

Screenshot 2023-12-01 132205.png

0 Ratings
Reply
423 Views
Message 3 of 4

Re: IPv6 on a Draytek router

Go to solution

Ah, the PPoE.

Happy for you.  Shouldn't need both SLAAC and DHCP though.

0 Ratings
Reply
419 Views
Message 4 of 4

Re: IPv6 on a Draytek router

Go to solution

Now that I have a working solution, I can start removing things one by one and see when it breaks 😉

0 Ratings
Reply