cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
362 Views
Message 1 of 12

Issue connecting JVC smart TV to new BT Hub

Hello

Have seen a few similar queries in here from years gone by, but none with fixes that have helped us - so hoping someone else might have a solution.

Our BT broadband was activated today, and every device in the house is happily using either a WiFi or ethernet connection, bar our JVC smart TV. We are picking the right network and entering the right password but every time the TV just goes back to the "not connected" network page even though the password is definitely correct and we don't get login error.

We have tried hard resetting the TV, we have tried using the WPS button on the router and the WPS easy connect option on the TV, we have tried turning 5ghz off (still can't connect) and then on again (still can't connect) our account doesn't appear to have the Smart Setup feature some people mention anywhere in the admin settings once accessed with the admin password (which appears to be because it's too new) and switching from WAP2 security to WAP-Auto security made no difference either.

By hotspotting the WiFi from my phone, I was able to get the TV online and confirm there are no software upgrades pending - it has the most up to date software it can have. It worked perfectly fine with our previous broadband/WiFi provider up until the switchover today. 

What else can I possibly try to get the TV to log on with our BT connection?

Thanks 

0 Ratings
Reply
11 REPLIES 11
319 Views
Message 2 of 12

Re: Issue connecting JVC smart TV to new BT Hub

303 Views
Message 3 of 12

Re: Issue connecting JVC smart TV to new BT Hub

Have you tried the following.

a) unplugging the TV for 60 seconds and then switch on and try connecting?               

If that doesn't work try

 b) factory resetting the Smarthub by pressing a pin into the recess button on the rear for about 10 seconds? Once it restarts try making the connection.

0 Ratings
Reply
271 Views
Message 4 of 12

Re: Issue connecting JVC smart TV to new BT Hub

Unfortunately that hasn't worked, but thanks for the suggestions all the same!

No other device is having any issues at all so I'm cursing JVC currently, just can't work out why it doesn't like the BT Hub when it had no issue with the other one

0 Ratings
Reply
259 Views
Message 5 of 12

Re: Issue connecting JVC smart TV to new BT Hub

I should add - it works absolutely fine with an ethernet cable connection (artistically run across the middle of the living room as the ultimate trip hazard, as the router can only be plugged in 2m away facing the TV/we await the arrival of a longer, uglier cable we can disfigure the entire perimeter of the room with) so it is only the WiFi it doesn't cooperate with for whatever reason 

0 Ratings
Reply
251 Views
Message 6 of 12

Re: Issue connecting JVC smart TV to new BT Hub

Seems to be a common problem with lots of similar threads. Sadly none with a resolution.

Powerline adapters might be a neater option.

237 Views
Message 7 of 12

Re: Issue connecting JVC smart TV to new BT Hub

One last thing that might be worth a try is manually setting a WiFi channel rather then leaving it on auto. For 2.4GHz try 1, 6 & 11. If the TV supports 5GHz anything other than the default 36.

0 Ratings
Reply
194 Views
Message 8 of 12

Re: Issue connecting JVC smart TV to new BT Hub

Thanks for the extra suggestion, unfortunately that didn't do it either but was worth a go! 

0 Ratings
Reply
183 Views
Message 9 of 12

Re: Issue connecting JVC smart TV to new BT Hub

While you should not have to do this it might be a work around and save you any more grief.

Buy a wireless access point and connect it to your Smarthub by Ethernet then try connecting your TV to the wireless signal that the wireless access point is transmitting. 

You can get a TP link TL WA801N wireless access point from PC World for about £23. If it doesn't connect to the TV you can always take it back for a refund.

81 Views
Message 10 of 12

Re: Issue connecting JVC smart TV to new BT Hub

Have you tried connecting with nothing else connected to the wireless and the 5GHz turned off.

I dont know how many wireless connections you have but if it is loads then the TV could be getting kicked off.

If for some reason that works, I would try and set a fixed IP to the TV so it doesnt have to worry about DHCP.

I dont suppose there is a weird setting in the TV that shuts of wifi if it isnt being used

 

 

 

0 Ratings
Reply