cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
4,431 Views
Message 1 of 4

SkyQ with smart hub 2 major connection issues quick fix

I thought I would share with the community 3 months of purgatory, hours on the phone to BT and Sky which resulted in complete dissatisfaction with the service.

When BT installed the full fibre we were all filled with anticipation the 900mb service was going to do to our online experience, turned out total disappointment!  I couldn’t keep the main Sky box connected to the internet or the mini boxes connected to the main box, combined with slow or No internet. 

I had Openreach, BT home experts and Sky engineers to no avail, the last BT engineer made a passing comment the only time he had seen anything like this before was when the customer had changed the SSID and password to their own choice.

After another day of of the usual unusable service I remembered what he has said, did a factory reset and everything now working as it should !!!!

I couldn’t believe this was the root of all my problems!

If you have any connection issues with Sky Q and smart hub 2 after renaming and using your own password do a factory reset on the router and re link anything on your WiFi

0 Ratings
Reply
3 REPLIES 3
4,423 Views
Message 2 of 4

Re: SkyQ with smart hub 2 major connection issues quick fix

@Imfifer 

Do not be surprised if you have to do a factory reset again in the future, as after a while, the home hub will run out of internal connections.

Try to avoid using  MAC randomisation or "private address" as its sometimes called, as this will hasten the need for a factory reset.

MAC randomisation is enabled by default on Apple devices, and also later Android and Windows devices.

If you have to do a factory reset and have BT Digital Voice, then make sure you export the stored phone numbers, as they will be deleted. You can import them again afterwards.

 

4,391 Views
Message 3 of 4

Re: SkyQ with smart hub 2 major connection issues quick fix

Set the 5Ghz channel to something other than 36 to avoid conflict with Sky Q

0 Ratings
Reply
4,390 Views
Message 4 of 4

Re: SkyQ with smart hub 2 major connection issues quick fix

You also need to make sure the hub is not using channel 36 for 5ghz network as that is used by SKYQ and causes WiFi problems. Just change hub 5ghz. Network channel to say 44 or 48



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply