cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
360 Views
Message 1 of 4

Slow broadband in one Mac but not in another

Hello,

I have just switched from Sky to BT Fibre with a Smart Hub 2.

My Mac Pro takes extremely long to load websites, and in many cases it just times out (error message, cannot connect to the server at www...) but sporadically loads the same websites extremely fast (difficult to ascertain a pattern). I also have problems to receive emails in the Outlook App. 

On the contrary my wife's Mac Air always loads the websites consistently fast. 

I have uninstalled FSecure and switched off the Mac firewall, and restarted the Mac, but it does not solve the problem.I have also disabled the 2.4GHz from the Smart Hub 2, and just using 5GHz.

My configuration seems very similar to my wife's laptop. Mine is running Mojave 12.40 and my wife's Mac Air is running 12.0.1.

Any idea of what could be wrong? Everything was perfect when using Sky.

Thanks very much!!!

 

 

Tags (2)
0 Ratings
Reply
3 REPLIES 3
312 Views
Message 2 of 4

Re: Slow broadband in one Mac but not in another

My guess would be that BT Virus protect initially caused the problem and although you have now uninstalled it, elements of it remain.

I know that Symantec do an uninstall tool for Windows machines which removes such elements, maybe they do one for MAC as well (?)

296 Views
Message 3 of 4

Re: Slow broadband in one Mac but not in another

Thanks very much!

I had FSecure (not BT antivirus) and I used their tool to uninstall it. 

Any other possibility that you could think of?

Greatly appreciate the input!

 

0 Ratings
Reply
285 Views
Message 4 of 4

Re: Slow broadband in one Mac but not in another

Check that your Mac is using the most up to date drivers for the wireless network card.

If you do an Internet search you will find out how to do that and if need be update them.

0 Ratings
Reply