cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mmc071
Beginner
301 Views
Message 1 of 6

WIFI upload speed of only 0.2mb/s

Go to solution

Hi,

I had Full Fibre 900 installed 10 days ago and up/down speeds from the hub are fine (930/112).

My issue is that when I do a speed test from any device connected on Wifi I get results of (300/0.2) -  yes, that's 0.2 up. It's the same all over the house, even when a device is placed next to the router.

Wired connection is fine (600/100).

How can the download speed be so good and yet the upload speed so bad? Surely that has to be a configuration issue or software/hardware issue, rather than something like interference? What can I do to troubleshoot this?

Thanks
Martin

0 Ratings
Reply
5 REPLIES 5
Mc6PE67
Beginner
282 Views
Message 2 of 6

Re: WIFI upload speed of only 0.2mb/s

Go to solution

Hi,

 

Also have full fibre 900 with halo 3 & 3 of the black discs, getting 930mbs to the router but max wifi speed is 120mbs throughout the hse, 3 x technicians been with the last one saying oh well thats the best you are going to get, some days I have checked the speeds and the upload speed is faster than the download, how is this possible, copper wire and dial up from 20yrs ago seemed better than fibre, it appears you can have 1000`s mbs coming into the house but no one offers a decent wifi. False advertising to say the least. 

0 Ratings
Reply
pippincp
Distinguished Sage
246 Views
Message 3 of 6

Re: WIFI upload speed of only 0.2mb/s

Go to solution

@Mc6PE67How can it be false advertising when full fibre is not sold as a wireless service?

TimCurtis
Guru
223 Views
Message 4 of 6

Re: WIFI upload speed of only 0.2mb/s

Go to solution

@mmc071 

Are you quoting speeds for both the 2.4 & 5gHZ bands?

Have you tried changing the wifi channels from auto selection to ones that might be less congested by checking with a wifi analyser?

0 Ratings
Reply
mmc071
Beginner
207 Views
Message 5 of 6

Re: WIFI upload speed of only 0.2mb/s

Go to solution

So it turns out the issue was related to 2 devices, and the fix was to uninstall the wireless adapter from Windows 10 Device Manager and reboot so they are re-added automatically. Now the same machines are getting 400 down, 100 up.

0 Ratings
Reply
mmc071
Beginner
201 Views
Message 6 of 6

Re: WIFI upload speed of only 0.2mb/s

Go to solution

Ok, solution was not exactly as above...

After getting to the full download and upload speeds, I re-created a Hyper-V virtual switch and then found that killed both the download and upload speeds - leaving worse than I was to start with!

I found the fixes here -> https://www.tenforums.com/virtualization/183576-very-slow-up-download-speeds-hyperv-external-switch-...

Now have full download and upload speeds and is working fine with Hyper-V configured and working too.

NOTE: UNLESS YOU'RE A DEVELOPER/ADMIN THAT USES HYPER-V THEN THIS THREAD WILL BE TOTALLY IRRELEVANT TO YOU AS THE ISSUE WAS CAUSED BY HYPER-V

0 Ratings
Reply