cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
7,285 Views
Message 1 of 12

BT TV Pro Set Top Box

Go to solution

Hi,

I've got the new BT TV Pro set top box, which on the whole has been a massive improvement on the earlier models of STB.  However, I've run into a couple of issues.

- Randomly, when waking the STB from standby I just get a black screen with the usual Home Screen graphics, a bit like the tuner hasn't been woken up.  In order to resolve this I just have to change channel and then it resolves the issue.

- Randomly, when waking the STB from standby I just get a solid purple/pink colour screen and the STB doesn't respond to anything.  Sometimes it self-resolves after a minute or two and other times (after a minute or two) it just reboots itself.

In order to try and resolve the above, I did a maintenance mode factory reset (keep recordings).  However, since then the STB only responds to the standby/BT button on the remote control and nothing else, which now means I'm stuck on the getting started screen and unable to progress any further.

Currently, an advisor has booked me an engineer visit (as the STB didn't respond to their remote instructions to reset), but it would be good to be able to use the STB in the meantime and watch my recordings!

Does anyone have any idea about how I might be able to force the remote to pair with the STB again, as it seems that's the behaviour its displaying at the moment?  I've tried going back into maintenance mode, but it's not even responding to the remote or any of the buttons on the STB to be able to do anything with it there either.

Thank you for any help in advance.

Best regards,

Darren

11 REPLIES 11
7,280 Views
Message 2 of 12

Re: BT TV Pro Set Top Box

Go to solution

Hi @darrendz1 

Have you tried unplugging it for a few minutes, it seems to fix most technology issues these days? 

7,274 Views
Message 3 of 12

Re: BT TV Pro Set Top Box

Go to solution
Yes, unfortunately no joy.
7,270 Views
Message 4 of 12

Re: BT TV Pro Set Top Box

Go to solution

The two video issues you mention are often seen with HDMI communication issues to the tv. Tried a different lead or TV HDMI port?

 

NeilO posted this on how to re-pair the remote.

f you need to re-pair your remote, follow these quick steps: 

  1. Press the Home and 9 buttons at the same time
  2. Hold down the buttons until the LED around the BT icon flashes purple three times

 

 


@darrendz1wrote:

Hi,

I've got the new BT TV Pro set top box, which on the whole has been a massive improvement on the earlier models of STB.  However, I've run into a couple of issues.

- Randomly, when waking the STB from standby I just get a black screen with the usual Home Screen graphics, a bit like the tuner hasn't been woken up.  In order to resolve this I just have to change channel and then it resolves the issue.

- Randomly, when waking the STB from standby I just get a solid purple/pink colour screen and the STB doesn't respond to anything.  Sometimes it self-resolves after a minute or two and other times (after a minute or two) it just reboots itself.

In order to try and resolve the above, I did a maintenance mode factory reset (keep recordings).  However, since then the STB only responds to the standby/BT button on the remote control and nothing else, which now means I'm stuck on the getting started screen and unable to progress any further.

Currently, an advisor has booked me an engineer visit (as the STB didn't respond to their remote instructions to reset), but it would be good to be able to use the STB in the meantime and watch my recordings!

Does anyone have any idea about how I might be able to force the remote to pair with the STB again, as it seems that's the behaviour its displaying at the moment?  I've tried going back into maintenance mode, but it's not even responding to the remote or any of the buttons on the STB to be able to do anything with it there either.

Thank you for any help in advance.

Best regards,

Darren


 

---------------------------------------------------------------
Fibre 2 Unlimited using EE Smart Hub 2 with EE TV Box Pro (UHD/HDR) in IP mode.
0 Ratings
7,258 Views
Message 5 of 12

Re: BT TV Pro Set Top Box

Go to solution
 
I found this on a BT site, hope it helps
 
BT RTIW387 - BT TV BOX PRO
  1. Start with the box powered off (i.e. no mains electricity connection) and the network cable unplugged

  2. Power the box on (connect mains supply).

  3. Hold down the round button on one end of the box.

  4. After 3-5 seconds, keep holding the button on the end, and now also start holding down the standby (front panel) button. So you are now holding down two buttons.

  5. After a further 3-5 seconds, release both buttons.

0 Ratings
7,186 Views
Message 6 of 12

Re: BT TV Pro Set Top Box

Go to solution

Hi @darrendz1 can you drop me a private message with your contact details and I'll see if I can help? Also if you did have one of the older BT TV remote controls around from the DTRT2100 or DTRT4000 boxes , they use IR and still work with the TV Pro box - the newer remote control units start on IR and should switch to Bluetooth once set up.

thanks

David

0 Ratings
7,085 Views
Message 7 of 12

Re: BT TV Pro Set Top Box

Go to solution

Sorry for the delay in replying.

For some reason I've had issues with the forums throwing up errors and then I've been on shift, so haven't been in a position to reply.

As ozsat mentioned, I managed (eventually) to find the post they mentioned from NeilO to re-pair the remote, which worked a treat.  About being an HDMI communication issue, I'm not sure it is to be honest.  Yes, I tried a different port, not changed the cable yet as it's the brand new one that came with the STB.  The behaviour isn't consistently repeatable and an HDMI communication issue shouldn't cause the STB to not respond to the remote (even just by flashing the LED on the front to acknowledge it's working) before it then reboots itself after a period of time, which is what has been happening.

I've also noticed (especially after the same issue happened again yesterday, 1 day after maintenance mode reset, that when it does reboot itself, it then shows most scheduled recordings (whether that day or in the future) as having failed that day, but with a random time (not the time it rebooted) and I have to go through manually and delete them all!

The engineer has been out this morning (I was impressed the appointment was so soon), but it was the first time he'd encountered the new STB.  As the issue couldn't be immediately replicated and I had photos of the issue on my phone, he replaced the STB, so we'll see what happens from here.

Also, thank you David_H, I'll drop you a message with some details.

Best regards,

Darren

6,579 Views
Message 8 of 12

Re: BT TV Pro Set Top Box

Go to solution

@darrendz1    Did you find a permanent resolution to your issue of...

Randomly, when waking the STB from standby I just get a black screen with the usual Home Screen graphics, a bit like the tuner hasn't been woken up.  In order to resolve this I just have to change channel and then it resolves the issue.  ??

My Pro Box has suddenly started doing the same this week.

 

0 Ratings
6,543 Views
Message 9 of 12

Re: BT TV Pro Set Top Box

Go to solution

Might be worth saying which channel it should be waking up on in case it is related. Perhaps a streaming issue where it is taken too long to start??


@scharterwrote:

@darrendz1    Did you find a permanent resolution to your issue of...

Randomly, when waking the STB from standby I just get a black screen with the usual Home Screen graphics, a bit like the tuner hasn't been woken up.  In order to resolve this I just have to change channel and then it resolves the issue.  ??

My Pro Box has suddenly started doing the same this week.

 


 

---------------------------------------------------------------
Fibre 2 Unlimited using EE Smart Hub 2 with EE TV Box Pro (UHD/HDR) in IP mode.
0 Ratings
6,530 Views
Message 10 of 12

Re: BT TV Pro Set Top Box

Go to solution

@ozsat  I'll keep a log to see if there's any correlation.....last one was ITV1HD.

Might be worth saying which channel it should be waking up on in case it is related. Perhaps a streaming issue where it is taken too long to start??

@scharterwrote:

@darrendz1    Did you find a permanent resolution to your issue of...

Randomly, when waking the STB from standby I just get a black screen with the usual Home Screen graphics, a bit like the tuner hasn't been woken up.  In order to resolve this I just have to change channel and then it resolves the issue.  ??

My Pro Box has suddenly started doing the same this week.

 

0 Ratings