Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 4

Epson WF-2530 printer + smart hub 2 problem

Go to solution

Hi all,

Here's one for a network professional / perhaps an Epson printer expert.

I have an Epson WF-2530 printer / scanner all in one that was working OK over WiFi until recently. Something changed, at the moment I assume that it was the v0.26.03.01286-BT smart hub firmware update that arrived on 19th April 2021, to make things go bad.

The state of things at the moment is that if I reboot the smart hub, the printer manages to WiFi connect to the hub for a short period of time and it works as expected. After a short while the printer then disconnects, it is no longer pingable and  it appears that it is no longer on the network. 

Things that I've tried: 

  1. DHCP enabled on the printer
  2. Static IP enabled on the printer
  3. A printer reset to factory defaults
  4. A firmware update on the printer which tbf is ancient, the latest available firmware for this printer is from June 2016
  5. I've played with the WiFi mode option on the hub. I've always had this set to Mode 1 and it has generally been fine. Attempting Mode 2 and Mode 3 didn't help fix this printer network problem but it did manage to cause disconnect issues with a couple of other network devices on the LAN so I've reverted back to Mode 1 again.
  6. I've run a wireshark trace which identifies that the printer is still alive after it has disconnected from the IPv4 network, I can see ARP broadcasts being sent from the printer's MAC address which seem to be getting ignored and are having no effect.

This problem almost feels like there's been an incompatibility introduced in the last smart hub firmware update coupled to the ancient crustiness of the printer firmware. This is nothing more than a guess to be honest.

The one thing that I've not tried yet is a smart hub reset to factory defaults.

Any ideas anyone / does this sound familiar at all ?

Thanks, Joe

0 Ratings
Message 2 of 4

Re: Epson WF-2530 printer + smart hub 2 problem

Go to solution

Possibly caused by the firmware issue that people are reporting in 

0 Ratings
Message 3 of 4

Re: Epson WF-2530 printer + smart hub 2 problem

Go to solution

To add to the above reply, there was also a fairly large update of Windows 10 together with some ad hoc bits and pieces in April.

We have an Epson WF-2540 connected by wifi to our Smart Hub 2 and although it has not given any problems lately, in the past, we simply powered off the printer, waited a few seconds and powered up again.

Just a point, having started again after a meltdown of my previous computer, I note, because I haven't reinstalled the Epson software, that the driver is now actually a bog-standard Windows job but it does everything we need. 

0 Ratings
Message 4 of 4

Re: Epson WF-2530 printer + smart hub 2 problem

Go to solution

A confirmed firmware bug is / was the cause of this issue.

After posting in and then subsequently reporting the issue directly to the forum mods via a direct message as requested, details of the problem were forwarded to the hub support team who later rolled out hub 2 firmware v0.26.04.04227-BT to my hub.

Following the firmware update the problem vanished. Fixed!

0 Ratings