Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 4


I have been having a nightmare connecting to BTWifi with my BT Broadband ID

I used this a few years ago when it was call BT-Wifi with Fon and it was adequate

I have been having difficulty staying logged in, the connection keeps dropping, I means as many as 200 times an hour

The login page is bloated and takes ages to load which just makes me hate BT even more.

It is SO hit and miss, then I decided to invest in a router with WDS to extend the BTWifi because the signal despite being 3 to 5 bars kept dropping and forcing me to login again and again and again, sometimes withing 10s of me logging in. It does this on multple devices including Apple and the BtWifi app is equally useless.

The first router a TPlink would not work, it used to work because I got it working a few years ago, so well done BT.

I then got another AC router, this one only shows one BTWifi network, the TPLink was better because it showed the Mac Address of all of them and you could choose the most powerful.

I AC Router I was now using has an option to do a survey and I moved the router into the best location where is said the signal was AC and was excellent. This sounded promising but it turned out not to be.

The router used WDS and works perfectly well with extending other wifi networks, but for some reason with BTWifi it keep forcing the user to login, it makes it completely unusable and is so frustrating it has turned me into a maniac.

Seriously, what is the point of offering this so called service if BT are going to make it so bad.

BT have gone to the trouble of writing an App so why not make sure your BTWifi works.

To anyone considering BTwifi access as a decision making benefit in considering BT broadband I would say DON'T, it is next to useless.

Why not make the BTwifi-X credentials used in the Apple app public or at least displayed in the BTwifi app so they could be used in WDS.

Surely it is in the interest of BT to have this functionality as widely available as possible.

My router has the option of extending the Wifi signal under my own SSID or to replicate, I have tried both, the latter does not show the improved signal so seems to be useless and does not connect anyway. Using my own SSID does connect but after a time (anything from 15s to 20m). Using my own SSID is preferable as it offers some level of security. The BTWifi hotspot has no security at all.

WDS is a standard technology in use by routers all over the world, so why does BT not support it, I know it worked before the SSID was changed from BTWifi-with FON to just BTwifi.

I still expect to have to key in my BT Account Login so I do not see the issue.

I suspect that the problem may be how BTwifi is implemented with so many signals around, I suspected that there is some signal threshold that is making it drop one and got to another, only to find that the other is rubbish and to go back to the first. In which case why not use the SSID BTWIFI-FSAFGP and make it a proper wifi that we can home in on.

If anyone has any solution to this problem I would be grateful to receive it, or if they know a way to get the TPlink routers to work with BTwifi as they used to with BTWifi-with-Fon then please comment.

0 Ratings
Message 2 of 4


I had/have the same problem. My thread is somewhere here on the forum. In case it helps I feel I had some success on my laptop by forcing my dual band adapter to use just one frequency band only (ie only 5GHz) but to be honest it still happens sometimes and is not as stable as it used to be.

Tags (1)
0 Ratings
Message 3 of 4


@Creole are you accessible BT WiFi on your own BT hub or using accessing or piggy backing on someone else's? If it's your own hub, don't select the BT Fon / BT WiFi option. Look for the hub id that matches your hub and log in using the password on the back of your hub. 

Accessing via BT Fon/WiFi will only let you access the public part which is limited bandwidth

0 Ratings
Message 4 of 4


@Creole You have been using BT-wifi for years? Wow! As @NigelB72 points out, you should access the net using your OWN hub id and the password provided (see Hub sticker). 

It might help you to read the following: