cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,985 Views
Message 1 of 11

Mode 2 not working following recent firmware update on SH2

Hi, i had lots of issues with my complete wifi, i then had to change the mode from 1 to 2 and things began working much better, since my router had a firmware update on 9/1/2021 my wifi discs will not connect on mode 2 or 3 and only on mode 1, but my wifi overall works very poorly on mode 1. What are my. Options to get the discs connected back onto mode 2?

 

Thanks 

0 Ratings
10 REPLIES 10
Anonymous
Not applicable
1,949 Views
Message 2 of 11

Re: Mode 2 not working following recent firmware update on SH2

If you have an old device that won't work correctly on mode 1 then you could buy a cheap USB network adaptor (cost around £5) to plug into it

0 Ratings
1,924 Views
Message 3 of 11

Re: Mode 2 not working following recent firmware update on SH2

I have this problem as well, disk will no longer pair with hub in mode2.
0 Ratings
1,917 Views
Message 4 of 11

Re: Mode 2 not working following recent firmware update on SH2

No its not to do with old devices not connecting its to do with the sh2 not working as it should in mode 2. Its to do with the firmware update i believe as issues are in the time frame of the update. 

0 Ratings
Anonymous
Not applicable
1,905 Views
Message 5 of 11

Re: Mode 2 not working following recent firmware update on SH2

@Shaunday442 

Sorry, I don't understand. Why do you want to operate your hub in wireless mode 2 if all of your devices are compatible with mode 1

0 Ratings
1,896 Views
Message 6 of 11

Re: Mode 2 not working following recent firmware update on SH2

Because the BT advice is to try mode 2 if you have problems in mode 1. I did and it worked. Now it is broken again after the firmware upgrade. What with this and the awful email client they have rolled out I suspect there are new engineers somewhere in BT who are simply not up to the job. Any other better providers than BT?
0 Ratings
1,870 Views
Message 7 of 11

Re: Mode 2 not working following recent firmware update on SH2

This is interesting. I just posted about my current issues with our Sky Q box constantly disconnecting from our network every evening - one of the suggestions was to try Mode 2.  When I did that all our devices kept dropping out and it said the network was unavailable. So agree there seems to be some sort of issue 

1,737 Views
Message 8 of 11

Re: Mode 2 not working following recent firmware update on SH2

Hi,

I have the same issue. I have a smart hub 2 and use ‘mode 2’ for my Sonos to work properly (it forgets speakers in mode 1). 

Both my Wi-fi discs stopped working after the recent firmware update.

I’ve spent hours on the phone with BT and had an engineer visit but it’s been suggested that I try the community forum for more support(?)

I’ve replaced the router and a Wi-fi disc but the discs will only pair in Mode 1 (switching to or trying to setup in mode 2 loses connection and I just get a flashing blue light).

Does anyone have a solution please or know how to get support from BT to fix the firmware issue?

thanks

 

0 Ratings
1,724 Views
Message 9 of 11

Re: Mode 2 not working following recent firmware update on SH2

As you say, the discs will only work if the SH2 is in wireless mode 1 and only BT's partners or whoever wrote the software can fix that. One workaround could be to connect (say) a mini hotspot such as the one below to the hub by ethernet cable to create a secondary 2.4GHz network

https://www.bt.com/help/user-guides/broadband-and-wi-fi-devices/wi-fi-and-home-networking/wi-fi-home...

0 Ratings
1,705 Views
Message 10 of 11

Re: Mode 2 not working following recent firmware update on SH2

Hi, thanks for the reply. I’m trying to avoid having to create a secondary network (the BT discs replaced one I had already and worked fine until the firmware update).

How do we draw attention to the issue with BT so they fix the issue with the firmware? Their customer service team had no escalation path for this kind of issue.
0 Ratings