Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 5

My BT app (Android)

In the last couple of days the app has stopped allowing me to log in. I last used it Monday or Tuesday (not 100% which) to order a couple of booster discs, but when they arrived yesterday i was unable to access the app to set them up.

Phone: Samsung Galaxy A21s

Give the "Something went wrong message" and either returns to the log in screen, or closes.


Tablet: Samsung Galaxy Tab A

Lets me put my pin in, then just 'hangs' with the little green circle spinning at the bottom.


I borrowed my daughter's iPhone 12 (yuck!) and installed the Apple version,  and it worked perfectly.


Both Android versions are up to date,  but have NOT updated between when I last used the app and yesterday. I have uninstalled the app, cleaned both devices and reinstalled app, same thing. Neither device is rooted.


Your people on Twitter thought its a Samsung issue, and were unaware this is a widespread issue according to the reviews on Google Play. Was told on Play to post here.

0 Ratings
Message 2 of 5

Re: My BT app (Android)

Go into the phone settings and force stop the MyBT app then try again

0 Ratings
Message 3 of 5

Re: My BT app (Android)

Thanks for the suggestion,  but that was one of the first things I tried.

0 Ratings
Message 4 of 5

Re: My BT app (Android)

Installed the app on to another (non-Samsung) phone, and exactly the same issue, which leads me to assume the app, or at least its latest update, is broken.

0 Ratings
Message 5 of 5

Re: My BT app (Android)

Hi @Darkson

I'd like to take a look into this for you to see what's going on. I've sent you a private message with some details that we need 🙂



0 Ratings