Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 11 of 20

Re: Slow speeds on certain apps/services only

Actually may have spoken too soon on Google Assistant - that's stopped working again.

0 Ratings
Message 12 of 20

Re: Slow speeds on certain apps/services only

I wanted to add a reply in case anyone looks at this thread in the future with a similar issue..

We've been through a lot more diagnostics on this one, playing around with some of the wireless network settings resulted in a slight improvement but there were still issues. BT are still looking into it but I ended up buying a new modem and router (non BT) and set that up this evening - so far everything seems to be working!

Will reply again if we're able to figure out more.

0 Ratings
Message 13 of 20

Re: Slow speeds on certain apps/services only

I have had the same issues as yourself.  None of the Samsung, Sony nor Microsoft Android devices can access certain web apps (e.g. Sainsburys, DPD and BT's own app).  I have, as you, tried all sorts of changes.  Ironically, switching off 2.4ghz channel fixed the problem but that means I can't use my Ring door bell device. 

Also, like yourself, when using the slower BT WiFi there are no issues. 

Which non-BT router did you buy? 

I believe the inability to use different SSID names for the 2.4 and 5 ghz channels may be the route of the issues.  

0 Ratings
Message 14 of 20

Re: Slow speeds on certain apps/services only

I bought Google WiFi for routing (which I think is great), but you still need something to act as the modem - there are options for this using your BT Hub but I wanted to remove it from the setup entirely. New standalone modems can be weirdly expensive (I needed a VDSL one for FTTC), the cheapest option I could find was to buy an old second hand Openreach VDSL modem on ebay (the type they used to install with new FTTC lines before the modem was integrated with BT's hubs), the Huawei HG612.

0 Ratings
Message 15 of 20

Re: Slow speeds on certain apps/services only

I have the exact same experience and has been driving me nuts. I was hopeful you had found the issue rather than a work around.

Did BT ever get back to you?
0 Ratings
Message 16 of 20

Re: Slow speeds on certain apps/services only

I believe the only option is to downgrade to the BT Home Hub 4. I did not validate this. 

0 Ratings
Message 17 of 20

Re: Slow speeds on certain apps/services only

This issue seems to persist... I found a few threads with the same issue and I am also suffering from it. Tried to move back to the SH2 as my own TPlink router doesn't provide the speeds I wanted on IPv6... Exactly the same apps are acting up, also using Google home, android etc... Must be some sort of setting in the SH2 that blocks certai Google ports? Perhaps a DNS issue? If I switch to 4g or use me VPN it works 😂

0 Ratings
Message 18 of 20

Re: Slow speeds on certain apps/services only

Mmm... interesting... I did a power cycle reset and noticed that my BBC apps and others that weren't working before worked until my TP Link Archer C7 v5 (set in Access Point mode only) connected to the BT SH2... So after a few minutes, those apps stopped loading again. I also noticed that some apps on my Windows PC (e.g., Outlook 365 - connected to the servers) were a bit sluggish...

I had a feeling that the TP link might be to blame for this (no clue why and how it affects the SH2 although it's set to AP mode only - but ok...)... 

So I ran a second power cycle - this time without the TP link connected and switched on - and ta-da! It seems to work now...

Also my Google Home devices are super responsive again (yesterday they just got stuck, didn't reply for seconds while all lights were on, and then said that there was a glitch and that I should try again).

One thing I also noticed was that now shows that I am on IPv6 (i.e., "IPv6 enabled"). It didn't show that during the previous power cycle or yesterday...

So I have two alternative explanations: somehow the TP link in AP mode interfered with the SH2 routing/DNS/etc... Or two power cycle resets just made it work (perhaps resetting the IPv6 settings to something that works better)...

Either way, I think it is time to take the TP link out of my set-up... It wasn't fast enough as a router in PPPoE mode (with IPv6 enabled) - and it seems to interfere with my connection if I use it as an Access Point only...

Luckily, I already ordered a second Unify AP... Let's hope this way I can finally enjoy my FTTP 900 connection without any issues :))

0 Ratings
Message 19 of 20

Re: Slow speeds on certain apps/services only


Had the exact same problem. Speed test and other downloads are perfect but playstore is extremely slow. A 21mb update showed about an hour kind of slow. Try enabling SIP ALG option under firewall settings. This fixed my issue. Tested on a few different android devices.

Correction: i take it back, its not working. It has gone back to normal. Couldnt find an option to delete this reply. Sorry.

0 Ratings
Message 20 of 20

Re: Slow speeds on certain apps/services only

Hi again, IPv6 is the culprit. Enable ULA under IPv6 settings > save. And it solves the issue.

Now i can go to sleep 🙂

0 Ratings