cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
2,091 Views
Message 1 of 11

Smart Hub 2 - One PC Dropping Connection

I have an issue that has only made itself apparent in the last 6 months - prior to that everything was fine. I have a Smart Hub 2, various wifi devices,  connected via ethernet to the hub I have a switch sharing the connection to a NAS, PC and laptop.

Issue

  • My PC, and only my PC (keeping in mind other ethernet devices connected, routinely loses connection. It was not always the case.
  • It is only with the Smart Hub the connection drops - Mini Hub, iPhone etc it'll hold the connection all day
  • When ethernet goes, I'm unable to connect via wifi either.
  • I'm on both laptop and PC for work and see that PC drops while the laptop doesn't

What I've tried

  • Turning off smart setup
  • Disabling power management on the network card
  • Updating drivers
  • Flushing DNS etc.
  • Restarting hub
  • Restarting PC (sometimes works - perhaps crucially it sometimes works initially and within a minute or two drops)
  • Removing BitDefender and reverting to standard MS AV/Firewall 
  • Trying new smart hub
  • Resetting network
  • Reverting to wifi
  • Troubleshooting ethernet/wifi adapters

If I leave it, eventually the connection will return. If I reset the network, that usually restores the connection but it will drop again.

Here are some of the examples of messages I get when troubleshooting - it's not always the same, and sometimes fixes are made, but mostly not

tinternet1.PNGtinternet3.PNGtinternet4.PNGtinternet5.PNGtinternet6.PNGtinternet7.PNGtinternet8.PNGtinternet9.PNGtinternet10.PNGtinternet11.PNG

Any help is much appreciated, as this is beyond frustrating! 

0 Ratings
10 REPLIES 10
2,076 Views
Message 2 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Try giving the PC a static IP address of 192.168.1.10, subnet mask 255.255.255.0, gateway 192.168.1.254 on the network card.

0 Ratings
2,067 Views
Message 3 of 11

Re: Smart Hub 2 - One PC Dropping Connection

I've added in the below, but TBH it's still the same. In fact, I've had to tether to my iPhone just to send this reply 😞

tinternet12.PNG

0 Ratings
2,023 Views
Message 4 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Are there any more suggestions for this? Ideally, I'd switch the smarthub out entirely but with the phones now plugged into it, this doesn't seem so straightforward.

Many thanks

0 Ratings
2,017 Views
Message 5 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Set DNS Server address to  192.168.1.254

Untick IPv6 on the network properties page.

Reset the home hub to factory default. That may affect the phone registration.

https://www.bt.com/help/broadband/how-do-i-reset-my-bt-hub-to-its-factory-settings

 

1,991 Views
Message 6 of 11

Re: Smart Hub 2 - One PC Dropping Connection

"My PC, and only my PC (keeping in mind other ethernet devices connected, routinely loses connection. It was not always the case."

Have you tried a new ethernet cable ?

0 Ratings
1,984 Views
Message 7 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Both changes made. Issue remains. Back tethered to my iphone 😞
0 Ratings
1,984 Views
Message 8 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Yep - new cable, different port - even a new switch.
Thanks for the suggestion though as it took a while for my brain to click it could be that.
1,962 Views
Message 9 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Have you tried using Google public DNS (8.8.8.8 and 8.8.4.4) or one of the other free public DNS servers 

1,943 Views
Message 10 of 11

Re: Smart Hub 2 - One PC Dropping Connection

Try the following to perform a full reset of the network settings on your Windows PC:

  • Open Control Panel > Network & Internet > Network and Sharing Centre

  • Click on the name of your internet/WIFI connection

  • Select "internet protocol version 4" and click on "properties" at the bottom.

  • Verify this configuration:

                      o  IP address automatically
                      o  DNS server address automatically

Now reset all the network configurations.

   •   Open a Command Prompt as administrator and enter:

  •  ipconfig /flushdns
  •  ipconfig /registerdns
  •  netsh winsock reset
  •  netsh int ip reset
  •  ipconfig /renew

Reboot the computer.
After it is also worth checking the connection properties are set for
Private rather than Public.