cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
3,384 Views
Message 1 of 8

Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

Hi, less than 1 wk after I switched to BT Broadband (not sure if ADSL or fibre, it's fibre only to the cabinet not between cabinet & my home AFAIK!), when my desktop Windows 10 PC resumes from sleep or hibernation, it has NO Internet connection at all. (It worked fine the 1st wk.) Realtek PCIe GbE Family Controller on my PC, connected to the BT hub (seems to be a Smart Hub 2) via a longish Ethernet cable.

In Network Connections, my Ethernet connection said "Unidentified network". To regain Internet access, I had to disable and re-enable it, then it all worked fine.

If I shut down fully and then boot, or restart, it does connect to the Internet automatically. The problem occurs only when waking my PC from sleep or hibernation. No problem with wifi connections to the hub using tablets etc. Never had a problem with my previous broadband provider Sky before I switched to BT Broadband, same PC, same Ethernet network adapter & cable. It could be a coincidence that the problem started less than a week after my switch to BT.

Things I've tried that didn't work:
- assigned a static IP address to my PC (what it had before when I was with Sky, but it seemed not to show it in IPv4 properties). Didn't change DNS, for which I use Google's 8.8.8.8. No longer said "Unidentified network" (but instead "Network 2", which is what it said when connected). Still no Internet access on waking from sleep. On diagnosing, I got "The default gateway is not available" or "Ethernet doesn't have valid IP configuration". Sometimes on diagnosing it resets my Ethernet and I have Internet access again, other times it doesn't and I have to disable and re-enable manually to get Internet access.
- disabled IPv6
- renamed Network 2 to Network 1 (which is what it was before)
- powercfg /h off
- updated my Realtek driver; also reset the BT router via the browser 192 etc webpage 

Has anyone else suffered this problem, and can anyone suggest any possible permanent solution please?

(I've given up and resorted to a temporary workaround - I created a batch file to disable and re-enable Ethernet, triggered to run via Task Scheduler on resuming from sleep, which is fast and at least saves me having to do it manually each time - I can post the details if anyone else needs the same workaround.)

Thanks in advance for any help.

0 Ratings
7 REPLIES 7
3,377 Views
Message 2 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

@Yev 

Welcome to this user forum.

Make sure you turn off "smart setup" on the BT Hub.

See link how to do that.

http://bt.custhelp.com/app/answers/detail/a_id/44328/~/what-is-smart-setup-on-the-bt-hub%3F-how-can-...

0 Ratings
3,374 Views
Message 3 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

Try disabling Energy Efficient Ethernet in "Client for Microsoft Networks".

0 Ratings
3,333 Views
Message 4 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

Thank you both, sadly disabling Smart Setup didn't work, and Energy Efficient Ethernet was already disabled (if you mean disabling "Allow the computer to turn off this device to save power" in the adapter properties - the box was already unchecked).

Any other suggestions would be gratefully received, and meanwhile I'll revert to my workaround.

 

0 Ratings
3,279 Views
Message 5 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

Hi, can anyone suggest any other possible solutions please?

I'm reluctant to hard reset my Hub as everything else is working fine - just Ethernet lost on resuming from sleep/hibernation.

Thank you.

0 Ratings
Anonymous
Not applicable
3,267 Views
Message 6 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

I suspect this may be something to do with your network adapter and the change in the gateway.

Try one of these methods

Method 1

Open settings ->Network & Internet ->Network Reset (toward the bottom of the page on the LHS of the RHS pane).

Method 2

Open a commend prompt

type ipconfig /flushdns- > Enter
type ipconfig /release-> Enter
type ipconfig /renew-> Enter 

0 Ratings
3,147 Views
Message 7 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution

Thank you very much Anon.

Method 2 didn't work - I forgot to mention I'd already tried it.

But Method 1 did! I waited to see, and the fix has persisted through several cycles of shutdown/boot and sleep/wake. Fingers crossed that it will continue.

So, if anyone else suffers the same Ethernet problem after switching to BT Broadband, I would recommend trying Method 1 first rather than the other things that I tried that didn't work.

Thanks again Anon.

0 Ratings
3,117 Views
Message 8 of 8

Re: Smart Hub 2 - ethernet connection lost on Windows 10 PC waking from sleep

Go to solution
In Device Manager, Network Adapters, Ethernet adapter, Power management - if "Allow the computer to turn off this device to save power" is ticked, it reconnects after waking from sleep. I think this is what the reset changed. If it's unticked, it won't reconnect after sleep. "Allow this device to wake this computer" makes no difference, ticked or unticked. Very strange why it should be the "turn off this device" setting that did it, I never thought of trying it before.
0 Ratings