cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
518 Views
Message 1 of 3

Premium disk network update fail

Go to solution

Hi, have just attempted a firmware update on my premium disks from 20823C to 208246. I have 4 disks. One connected to router, the others in a wireless chain. I initiated it from the app. 

All disks went purple. 3 came back blue and one red. The 3 blue ones appear to be giving Internet however.... 

1 disk won't connect. I've tried turning everything off and bringing them up one at a time but no change. Goes purple, flashing blue, then red. 

The app shows the 3 working devices with the number of connections but never gives me access to them. I permanently have a 'something went wrong' message and alternating dots over the top of the app display.

I've tried switching everything off but the master disk but app won't even connect to that completely - same message. 

Do I factory reset everything and start again? What firmware will the revert too? 

0 Ratings
Reply
2 REPLIES 2
510 Views
Message 2 of 3

Re: Premium disk network update fail

Go to solution

It would be best to give the WHW product helpdesk a call on 0808 100 6116 ( Mon to Fri 9am to 5.30pm and Sat 9am to 2pm) or drop them an email to: btconnectedhome@bt.com and they'll be happy to help.

0 Ratings
Reply
500 Views
Message 3 of 3

Re: Premium disk network update fail

Go to solution

For anyone reading this with a similar issue, this is how I fixed it. 

1. Factory reset each disc

2. Unload and reload App.

3. Add a new 2 disc setup (3 or more wouldn't work for me and failed each time I tried). Leave disks 3/4 off. 

4. Use 'add a disk'  for subsequent disks which uses WPS. This fixed my 'lost' 2 disks.

5. Reset all your network settings!

Despite my system failing to recover after the update all my disks now report the new firmware. 

Let's hope it was worth it!?! 

0 Ratings
Reply