cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,351 Views
Message 1 of 11

BT TV Pro box sometimes fails to get current time

I have a problem with my BT TV Pro box - it has SMART standy mode enabled and occasionally when it comes out of standby it seems to fail to get the current date and time.  So for example today when it started up at just before 3pm it didn't set the time so it seems to start at 00:00 on some prior day (I couldn't find anywhere in the UI where it shows this date).  The guide was blank and none of the apps were showing and it failed to record the program at 3pm - it showed a YMV104 error although my router shows the box as connected.  So if the box has been up 2.5 hours the time on the box shows as 02:30.

I have tried several different BT TV Pro boxes and have the same issue - I have also tried both wired and wireless connections and both show the same intermittent issue.  I have BT FTTP with a pfSense router.  I am guessing it must be some issue with my equipment or DNS settings (I use 1.1.1.1) but does anyone have any ideas?

Once the time is wrong it never tries to fix it and so from then on the box doesn't record anything or connect to the internet.  Once the box is restarted by pulling the power cable it works fine.  I have had to fit a wifi power plug so I can restart the box remotely when it fails to start.

____________________________________________
BT FTTP 500/75 + pfSense + 4 x UniFi Wifi 6 Pro
0 Ratings
Reply
10 REPLIES 10
1,334 Views
Message 2 of 11

Re: BT TV Pro box sometimes fails to get current time

Never used Pfsense but if the issue is purely on of time sync, there a video here about configuring Pfsense itself as an NTP server.

https://www.youtube.com/watch?v=r5cP1T_Gc60

No idea if the Pro Box can accept a time sync this way but may be worth a try as it doesn't look too involved.

But the error message & lack of a program guide makes me think the box just isn't communicating with the Web. We;ve seen various threads where the Box complains about no connection even when hard wired.

0 Ratings
Reply
1,332 Views
Message 3 of 11

Re: BT TV Pro box sometimes fails to get current time

The box must maintain an internal clock because it know when to wake up so I don't understand how this clock can then be reset to some default time if it fails to get the current time from the internet.  I assume it fails to download anything from the internet because it may be using https which will require a roughly correct date to validate the certificates.

____________________________________________
BT FTTP 500/75 + pfSense + 4 x UniFi Wifi 6 Pro
0 Ratings
Reply
1,315 Views
Message 4 of 11

Re: BT TV Pro box sometimes fails to get current time

Could you cope with using BT's DNS for a few days (depending how often it occurs), just to rule that out? Or configure the box itself to use one of BT's DNS servers.

Also, are you connected to a TV aerial? That also provides a time signal.
0 Ratings
Reply
1,313 Views
Message 5 of 11

Re: BT TV Pro box sometimes fails to get current time

Yes I am using an aerial so I am surprised it never updates the time from that.  I have changed DNS on the BT Pro Box to Google (will try BT DNS as well if that still fails).  I am also now setting the NTP server in DHCP to use my pfSense router though not sure whether the BT TV Pro box will use that NTP setting.

____________________________________________
BT FTTP 500/75 + pfSense + 4 x UniFi Wifi 6 Pro
0 Ratings
Reply
1,299 Views
Message 6 of 11

Re: BT TV Pro box sometimes fails to get current time

You don't appear to have ever had a BT TV subscription on your account. BT TV Pro boxes aren't resaleable and remain the property of BT at all times, so you're limited in what support you'll get on this I'm afraid.
0 Ratings
Reply
1,031 Views
Message 7 of 11

Re: BT TV Pro box sometimes fails to get current time

Just an update on this issue - my pfSense router was already enabled as an NTP server so I added its IP address to the DHCP NTP Server and also explicitly set the DHCP DNS address for the BT TV Pro box only to Google DNS.  With these settings everything worked fine - I then changed the DNS to Cloudflare and that also worked fine for the past two weeks.

Yesterday I removed the DHCP DNS address for the box and today it failed to load the TV Guide - just says Guide Preview unavailable.  It does show the correct time and the apps are available so internet connection is fine but seems to have a problem with getting the guide data.  The info button also doesn't work due to missing guide data so it seems I need both fixes in place.  Just posting this in case anyone else comes across the same problems.

____________________________________________
BT FTTP 500/75 + pfSense + 4 x UniFi Wifi 6 Pro
0 Ratings
Reply
630 Views
Message 8 of 11

Re: BT TV Pro box sometimes fails to get current time

May I ask how you were able to get BT TV functioning with Pfsense? I haven't had much success.

0 Ratings
Reply
607 Views
Message 9 of 11

Re: BT TV Pro box sometimes fails to get current time

At lot of such boxes no longer have their own real time clock, but rely on the network they are connected to.  Such boxes often grab time during or shortly after DHCP (the service is not tied to DHCP).  You should be easily able to set up the pFsense box to broadcast a time signal on 192.168.1.255 (assuming a 192.168.1.0/24 subnet) which the box should pick up.
As the issue is not being shouted about all over the forums, I'd assume this has to be a local setup issue not a global one based on the box firmware.  I'd be looking at an NTP config error/omission on the pFsense box!


I only learn by making mistakes and owning up to them - boy do I learn a lot!
0 Ratings
Reply
588 Views
Message 10 of 11

Re: BT TV Pro box sometimes fails to get current time


@Crimliarwrote:

As the issue is not being shouted about all over the forums, I'd assume this has to be a local setup issue not a global one based on the box firmware.  I'd be looking at an NTP config error/omission on the pFsense box!


In the end I tracked it down to some sort of incompatibility with the managed Netgear network switch that the BT box and the nearby Unifi access point were both connected to.  I swapped it out for another Unifi switch and I have had no further issues with the box failing to get the time on start-up.  I still think that there is an issue with the BT box firmware as it should be able to use the current time from the aerial signal if it fails to get it from the network.

____________________________________________
BT FTTP 500/75 + pfSense + 4 x UniFi Wifi 6 Pro
0 Ratings
Reply