cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
2,605 Views
Message 1 of 8

Heatmiser Neo Hub Connection Issue

I have a heatmiser neo hub heating system which is working fine in my house with the remote controls, however I am having issues connecting to my heatmiser app on iphone with it saying 'All devices offline'. 

Heatmiser support have sent me the following.. 

'The BT engineer is mistaken. The BT smart hub only searches for other Wi-Fi devices, the neohub system does not use Wi-Fi so the BT hub would not even see it. But they both use the 2.4Ghz ISM band so the router which is between 10 and 100 times more powerful than the neohub can block the radio signals. The feature that automatically changes channel actually makes things worse, because it allows the bt hub to change channel and cause problems where there were none before. 
Your neohub is operating on ZigBee channel 11, if your BT hub is operating on any channel below Wi-Fi channel 5 it will interfere with the signals being sent to and from the neohub effectively cutting the connection, which results in all devices being offline. 
The solution is to fix your router channel so it does not change in this case any channel from 6 upwards.' 

I sent the above  message to the bt support chat team and their response was the following...

 

Ranik: Good afternoon! Hope you are doing well today 🙂 I understand that you are facing an issue connecting the heating app to your iphone, and you have messaged the heating company and they have informed you that it will work on the 2.4Ghz network and ISM band. I appreciate you letting us know. However, as you are through to me now I will definitely go ahead and try my best to get this sorted for you.
Just to let you know, as they have stated the BT engineer is mistaken, he is not. He knows the hub configuration better than the heating company, these are the special tech engineer's whose only work is to make sure that you are connected with the devices. All of the devices are connected I assure, then why only the heater is not getting connected, this has nothing to do with the bandwidth if you have a Smart hub, as they have an auto channel scan the devices will only get connected to the best channel available. However, still I will definitely check this for you and try my best to get this sorted.

Our main environment is working on the connection and before passing a comment on an engineer they must have at least visited the property. This is an issue with their device, still as you are a valuable customer to BT, we have sent an expert engineer to you at no charge to check this and share all the details. However, what is the heating company doing? It's their equipment they should have at least visited the property and help you with all checks. leave it to us, if required we will again send an expert engineer, to check this for you. However, if this still persists, I think it will be best to once let them know.
Firstly they are trying to tell you that the Smart hub 2 must not operate beyond 5Ghz or it will interfere and affect all the connection. They must know the basics that all hubs have the 2.4Ghz bandwidth and the 5Ghz bandwidth. However, some of the IOT devices which are known for connection with the app and then the devices, they all get connected with the 2.4Ghz bandwidth.

Now, to be more clarified what are these two bands 2.4 and 5. They are nothing but the devices with the best channel get connected. Like if a device is further away from the hub it will get connected with the 5Ghz and if that is close to the hub
it will get connected with the 2.4Ghz.However, as these devices work on the 2,4Ghz only, I can do one thing which will be best. I will go ahead and disable the 5Ghz band and only open the 2.4Ghz band which will help the heating device to get connected and once that is connected we can open both the bandwidth. It is possible to turn one or both of the 2.4Ghz & 5Ghz bands off. Some IoT devices may require 5Ghz to be disabled to install them. Re-enable 5Ghz after IoT is successfully connected.
15:27, Jan 11
Ranik: Please wait while updating the Wi-Fi settings The process should take no longer than 2 minutes......
15:29, Jan 11
Ranik: The changes you have selected have now been made.
15:29, Jan 11
Ranik: Band 2.4Ghz 5Ghz Current Setting Enabled Disabled
15:31, Jan 11
Ranik: I have now made the changes, now can you please go ahead and press the WPS button at the back of the hub and then
try to connect the heating system. Reboot it once and then try to connect. I'm right here. No need to rush 🙂
Thank you so much for trying all the checks with me, but it looks like there is some issue with the heating device or their app. Everything is connected with the network, and all the devices are getting connected through WiFi and ethernet cable. I would request you to please once let them know, that we have gone ahead and enabled the 2.4Ghz and disabled the 5Ghz and checked if it gets connected but still there is no luck.
15:46, Jan 11
Ranik: We have also sent an engineer and checked the whole connection, if there was any issue I can assure you the engineer
would have detected it.
15:47, Jan 11
Ranik: I feel sorry that you have to go through this and you have to contact the company, and I wish I could make it any better. However, we have tried everything that is possible from our end now.'
 
I seem to be being passed between the two companies and don't have a solution to get this fixed so I can control my heating from my phone. Any help on this would be much appreciated. 🙂 Thanks. 
0 Ratings
Reply
7 REPLIES 7
2,597 Views
Message 2 of 8

Re: Heatmiser Neo Hub Connection Issue

That's far too much text to wade through.

Summary seems to be that all of the heating is working correctly, you just can't connect the app?

Heatmiser seem to be barking up the wrong tree, as presumably their Hub is already talking to the rest of the system to make it work. Therefore if the issue was with interference, the system wouldn't work at all.

Do they have access via a web browser you can test control access with?

If not, try turning the WiFi off on your phone & see if you can connect using 4G.

0 Ratings
Reply
2,563 Views
Message 3 of 8

Re: Heatmiser Neo Hub Connection Issue

If the heatmiser hub is attempting to connect to your phone in ad-hoc mode at 2.4Ghz, your phone won't see it if it connecting to your BT hub at 5Ghz. You need to force the phone to 2.4Ghz either by turning off the 5 Ghz WiFi on the BT hub or move further away so that your phone switches to 2.4Ghz.

0 Ratings
Reply
2,560 Views
Message 4 of 8

Re: Heatmiser Neo Hub Connection Issue

A poor response from BT there. Your neohub connects to your BT Smarthub by ethernet cable, not wifi. Have you checked that the ethernet cable is fully plugged in? The neohub then uses the entirely separate Zigbee wireless system to communicate with the other components of your heating system, your BT wifi isn't involved.

If what the heatmiser rep says about interference between wifi and Zigbee wireless is correct then that is a bad design feature of Zigbee. The workaround they gave is to switch off smart channel selection on your Smarthub and fix the 2.4Ghz band to a channel higher than 6 - try 11.

0 Ratings
Reply
2,551 Views
Message 5 of 8

Re: Heatmiser Neo Hub Connection Issue


@steephill wrote:

A poor response from BT there. Your neohub connects to your BT Smarthub by ethernet cable, not wifi.


How on earth would BT be expected to know that.

0 Ratings
Reply
2,546 Views
Message 6 of 8

Re: Heatmiser Neo Hub Connection Issue

BT chat - "Everything is connected with the network, and all the devices are getting connected through WiFi and ethernet cable."

0 Ratings
Reply
2,537 Views
Message 7 of 8

Re: Heatmiser Neo Hub Connection Issue

????

0 Ratings
Reply
1,236 Views
Message 8 of 8

Re: Heatmiser Neo Hub Connection Issue

I have the same problem and I don't know what to do. Did you manage to fix it in the end?

thanks!

0 Ratings
Reply