cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
422 Views
Message 1 of 4

App has never worked for speed testing

I have the FTTP 900mb package, and like most people my speeds are around 300mb on iPhone and even wired directly into the smart hub 2 via my laptop according to external speedtesting.

So I wish to try the BT app and 'Test My Speed' - the test runs fine, but instead of displaying my results I always get the error ""! We're sorry, something went wrong" then "Run the speedtest again - we're sorry , we are still having trouble testing your internet speed."

This has been the case every single time I have tried to do this since install.

Any advice?

Thanks, Ed

Tags (3)
0 Ratings
Reply
3 REPLIES 3
152 Views
Message 2 of 4

Re: App has never worked for speed testing

I’ve come here to see if I can find this out too. It’s never worked for me either. Just tells me to restart the hub and sends me to the new troubleshooter

0 Ratings
Reply
142 Views
Message 3 of 4

Re: App has never worked for speed testing

try fast.com



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
135 Views
Message 4 of 4

Re: App has never worked for speed testing

Can you submit those results to BT if they are below what you’re guaranteed as part of your contract?

 

0 Ratings
Reply