Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 8

Problem Setting Up DDNS - any ideas?

Bit of a long intro here, but bear with me.

I have fibre to the door with an ONT on the wall and everything works terrifically with my Asus RT-AX88U router. Land line is over copper rather than DV.

I'm trying to set up separate, direct, external access to my Synology server which sits on my network. But BT don't do static IPs for domestic customers so I have to use DDNS.  No problem in theory, because it works on the router.

However, - the Synology server (running the latest update DSM 6.2.4-25556 UD 6) won't set up to talk directly to the outside world straight through the router because it detect two routers on the network.  There's only one.  ☹️ There's no other extenders, WAPs or other router-like components either; just a couple of 24 port Level 2+ switches.

Checking with the Synology community, it looks like it it is detecting a second, fibre router, upstream of my incoming service.  Seems to be a fairly common problem with loads of Synology users pulling their hair out and similar responses.  Presumably the "other" router in a local green box or back at the local exchange.  Either that, or it sees the ONT as a router even though it's only a glorified modem.

So, I appear to be stuffed, unless I want to use DDNS as far as my own router and then have to log into the Synology server every time.  I don't want to do this because I'm trying to give a third party a restricted access to only a small, protected part of the server, not to my entire flippin' network.

Has anyone come across this or anything similar? If so, any ideas? 


Tags (2)
0 Ratings
Message 2 of 8

Re: Problem Setting Up DDNS - any ideas?

There are obviously multiple routers upstream of your network in the wider internet , so not sure why the Synology considers that a problem. However, it may be because the default gateway ( the BT BRAS)  has a private IP address rather than a public one. 

0 Ratings
Message 3 of 8

Re: Problem Setting Up DDNS - any ideas?

Not sure exactly what you mean by BT-BRAS, it's not a term I've come across before. But I should mention that I've also tried getting rid of the "default DNS gateway provided by IP provider " option and instead I've tried several of the popular and faster DNS services like Cloudflare, Quad9 and even (in desperation) Google. No joy.

Thanks anyway though.

0 Ratings
Message 4 of 8

Re: Problem Setting Up DDNS - any ideas?

The BT BRAS (Broadband Remote Access Server) is the the gateway from your home network and is the first router you encounter on the internet.

Message 5 of 8

Re: Problem Setting Up DDNS - any ideas?

Look at your router settings to find the broadband IP address, and make a note of it.

Then visit and see if your public IP is the same.

If they are not the same, then you could be on a shared IP address (CGNAT), which should not be the case, as your IP address should be unique to you for each session.

I was not aware that BT use CGNAT, so there could be a mis-configured network element.

If they are the same, then a DDNS service should work without issues, provided the router`s update API is correct, for the DDNS service you are using.


0 Ratings
Message 6 of 8

Re: Problem Setting Up DDNS - any ideas?

I'm convinced the problem lies with Synology having a problem with seeing a private IP address as the next hop.

0 Ratings
Message 7 of 8

Re: Problem Setting Up DDNS - any ideas?

Message 8 of 8

Re: Problem Setting Up DDNS - any ideas?

Thanks for that Keith.

Not an option I was aware of. I've checked both local and external versions of the IP addresss and sadly, they're both the same.

Thanks for that also Les.

Yes, I'd been at the Synology page (plus about a  dozen others) and tried everything except, if I'm honest, checking a different internet time service, because the DS411+ seems to keep perfect time on the NTP I have it set to.

The problem comes well before I try to actually set up a DDNS link.  An initial step along the way is to "Set Up Router" - it does a load of test and detections, recognises the router and sets up the required ports on the router. But after correctly detecting the Asus and all it's parameters it spots the "two routers on network problem" and puts up a red flag.    It appears to go through the remaining steps of setting up the ports, but at the end of it it all still doesn't work.  If I set ports manually I get the same result.

The extremely unhelpful suggestion on screen is to put the router into bridge mode, which to all intents and purposes would turn it into a very stylish four-aerial plastic brick sitting on top of the 19" rack in my loft.

Synolgy make terrific servers and NAS devices, but boy oh boy they can be difficult to get just right.

If only BT would offer static IPs all this would be easy. 

The annoying thing is that their subsidiary PlusNet, using exactly the same equipment (if all you want is FTTC), does offer static IPs for a very modest charge.  I can't remember if it was a couple of quid a month or just a one off charge, but it was peanuts when I was with them.  But of course they've segregated their market offering, PlusNet withdrew their nascent FTTP product and I'm stuck with trying to find a way through the BT maze.