Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 2

Parental Controls not working

Hi BT Community

My parental controls have not been working for the past 3+ months, ever since I requested an upgrade to Full Fibre.

Before upgrading, using the 'old' BT Smart Hub the Parental Controls worked fine.

Ever since requesting the upgrade, NONE of the parental controls have worked including none of the excluded sites.

My kids have potential access to every seedy and sordid corner of the Internet.  Great.

I'm still waiting for full fibre to be installed, apparently I need a new telegraph pole in my garden!

Meantime I have got the new Smart Hub 2 up and running, in non-fibre mode, and still the parental controls DO NOT WORK.

I have had numerous chats and conversations with well-meaning but ultimately ineffective technical experts at BT, switching parental controls on and off, reseting the hub, checking the DNS server is pointing at BT, etc and nothing has changed.  Full bore access to everything, good and bad.

The latest twist to this ongoing saga is this:

Parental Controls won’t work on iOS devices with iOS 15 or later when browsing on Safari and for some app traffic when iCloud Private Relay is enabled.

We have ios and macos devices, but Private WiFi/Relay is disabled and we have a windows device - the parental controls don't work on any device.

It has to be something at the BT back end, surely, unless someone has a bright idea or experience to the contrary?

I throw myself at the mercy and wisdom of the Community. @DarrenW  ??

I'm all ears.


Tags (1)
0 Ratings
Message 2 of 2

Re: Parental Controls not working

Hi, @mrburger I'm so sorry your parental controls have stopped working. I've seen this happen before when a Fibre upgrade has been delayed and it is due to a mismatch with our system records. I'll send you a private message so you can get in touch and we'll be happy to help.



0 Ratings