cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
491 Views
Message 11 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

It can be very useful on the pi to edit /etc/dhcpcd.conf and uncomment "slaac hwaddr" as this will generate a fixed link-local address based on the MAC address of the Pi.

As for my settings in AGH, the only major change was to remove the suggested DNS servers and add "tls://dns.quad9.net" which gives me the base Quad9 IPv4 and IPv6 DNS servers.


I only learn by making mistakes and owning up to them - boy do I learn a lot!
0 Ratings
Reply
458 Views
Message 12 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

Why wouldn't it have a IPv6 WAN IP? I'm sure it did when using BT's Smart Hub 2

0 Ratings
Reply
452 Views
Message 13 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

It doesn't need one, IPv6 is different to IPv4. All your devices will have a public IPv6 address.

441 Views
Message 14 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

So when you are using IPv4 everything gets sent to the router that sits at the WAN IP address, and then the router has to sort out it out and send it off to the devices on the LAN.

On IPv6 your router has it's own IPv6 address, as does everything behind the router have a directly addressable IPv6 address.  So the closest you get is the IPv6 prefix which is the common part of the IPv6 addresses that all your devices share.  If you pull up the network connection details, you'll still see an IPv6 "default gateway", but it's a LAN facing "local" (fe80::) address. 

*Individual devices can have multiple IPv6 addresses.  They'll often have a gobal address assigned by the router, a global address created using their MAC address as a base, and local address versions based on those two, so four is not uncommon.  A couple of things running on one of my Raspberry Pi's do not only use port numbers but have their own IPv6 addresses too!  The router has to do an awful lot more work than it used to!


I only learn by making mistakes and owning up to them - boy do I learn a lot!
430 Views
Message 15 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

NJackooo_0-1691438094012.png

I think I've got it working then via 6to4 Tunnel, devices have a 2002: address from the tunnel and also an fe80 address.

 

But then this still happens?

NJackooo_3-1691438423809.png

 

0 Ratings
Reply
423 Views
Message 16 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

I'd kinda glossed over this but:  You shouldn't be using 6to4 tunnel, on BT the IPv6 protocol should be "Native" and with a /56 prefix.  On most routers, you won't even need to identify the/56 prefix!


I only learn by making mistakes and owning up to them - boy do I learn a lot!
0 Ratings
Reply
420 Views
Message 17 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

It doesn't seem to want to save with these settings.

 

NJackooo_0-1691439439712.png

 

just says operation failed 😞 I've read others have had problems due to the /56 prefix, or rather TP-Links reluctancy to support it 🙄

0 Ratings
Reply
410 Views
Message 18 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

Try DHCPv6 or failing that Auto for Get IPv6 Address

0 Ratings
Reply
402 Views
Message 19 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

It just gives me constant operation failed for anything under the PPPoE setting

0 Ratings
Reply
397 Views
Message 20 of 55

Re: IPv6 on TP-Link Archer AX95 with BT Full Fibre

Go to solution

What options do you get if you untick 'Share the same PPPoE session with IPv4'

The IPv6 settings are not related to PPPoE, its a different setting.

0 Ratings
Reply