cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
721 Views
Message 11 of 23

Re: Smarthub 2 and RDP connection

Go to solution

Hi,

I need to setup a connection, so I need to be able to establish a two-way communication.

This is what I get

 

screendshot.png

 

 

 

 

 

 

So, while I believe the outboud traffic works, the connection does not get established.

 

Thanks

0 Ratings
Reply
721 Views
Message 12 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@Les-Gibson 

Sorry. What information is missing?

0 Ratings
Reply
712 Views
Message 13 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@pfbini 

Check that you have provided your public IP address and not your local network address.

The remote computer is not responding to a ping request. I assume you are using the ping command?

Try using PortQuery instead.

https://www.thewindowsclub.com/how-to-use-port-query-tool-portqry-exe-in-windows-10

 

 

710 Views
Message 14 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@pfbini wrote:

 

The IT manager for the box I need to reach thinks that it's a NAT issue, I'm not sure and hope I won't have to change provider just for this.

 


Then the IT manager is clueless if he thinks that NAT is causing a problem for an outbound connection. The problem is at his end.

As a silly question, what have you told him your IP address is? 192.168.1.82 or your public IP address?

Edit: typing as Keith posted

0 Ratings
Reply
703 Views
Message 15 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@licquorice 

I have given him my public IP address, as mentioned in another reply.

0 Ratings
Reply
686 Views
Message 16 of 23

Re: Smarthub 2 and RDP connection

Go to solution

I'm not familiar with RDP server configs and can't see how it could possibly check, but the only thing I can think is that it is somehow checking the incoming public and private IP address combination and as the hub private IP addressing range is different to Virgin, the server doesn't like it.

0 Ratings
Reply
681 Views
Message 17 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@Keith_Beddoe 

For example the Test-NetConnection on another IP protected server works as expected on port 1433 from two laptops both connected to the same Smarthub because the external IP has been enabled.

I guess the trace on PowerShell reads the IP inside, but the connection is made with the external IP

As you may see in another reply I'm not using ping. Will give PortQuery a try.

 

Thanks

0 Ratings
Reply
680 Views
Message 18 of 23

Re: Smarthub 2 and RDP connection

Go to solution

The PortQuery utility was specifically intended for checking the status of remote ports.

There is a GUI front end for that utility which is useful if you need to check a lot of ports.

Another program is Zenmap which can test for a single port, or a range of ports.

https://nmap.org/zenmap/

A very useful program.

 

 

0 Ratings
Reply
654 Views
Message 19 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@pfbini 

If you really want to prove which end it is, I have a tiny bench test Windows 10 PC which has RDP enabled. I can PM you my IP address and you can see if you can get as far as the login screen.

If you can, then that proves your outgoing request is being sent over the BT network.

 

648 Views
Message 20 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@Keith_Beddoe 

Very kind of you and of course I'm happy to try.

Thanks!

0 Ratings
Reply