cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,851 Views
Message 1 of 23

Smarthub 2 and RDP connection

Go to solution

Hi everybody,

I'm trying to connect to a remote desktop but it does not work.

I have created a port forwarding rule for port 3389, checked that webprotect is off and done a factory reset, but nothing changes.

Any suggestions?

Many thanks!

Pierfranco

0 Ratings
Reply
22 REPLIES 22
1,829 Views
Message 2 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@pfbini 

Welcome to this user forum for BT Retail phone and broadband customers.

You do not need to do any port forwarding if you are originating the request, however the remote computer would need to allow incoming connections on port 3389.

If you are using Windows, then Windows Firewall normally enables port 3389  for outgoing and incoming connections when the RDP request is initiated.

 

0 Ratings
Reply
1,803 Views
Message 3 of 23

Re: Smarthub 2 and RDP connection

Go to solution

Remote desktop connections cannot be made to devices running Windows Home editions (although it can initiate an RDP to a machine running a Windows Pro edition).

If your machine is running a Windows Home edition then download the free TeamViewer instead.

0 Ratings
Reply
1,797 Views
Message 4 of 23

Re: Smarthub 2 and RDP connection

Go to solution

Thank you for your answer.

The receiving server has been configured to allow my current IP and the 3389 port is open.

I had the same problem with another RDP server, but I was able to solve it by adding an IPV6 pinhole to the smarthub configuration, which in my opinion confirms that the smarthub 2 out of the box is not configured for this kind of traffic (and it also rules out any possible problems with the  windows firewall)

The IT manager for the box I need to reach thinks that it's a NAT issue, I'm not sure and hope I won't have to change provider just for this.

Is there a tech support available for these issues? I tried the chat on BT but was told it's only for issues with the broadband service per se...

Any help would be greatly appreciated, thanks!

Pierfranco

0 Ratings
Reply
1,793 Views
Message 5 of 23

Re: Smarthub 2 and RDP connection

Go to solution

Hello,

thanks for your reply. It is a windows professional box and I never had any issues with Virgin, I'm afraid.

I need to get to a windows server via RDP and TeamViewer is not an option (it would not be free when using it for work anyway)

Best,

Pierfranco

0 Ratings
Reply
1,773 Views
Message 6 of 23

Re: Smarthub 2 and RDP connection

Go to solution

You may have just answered your own question.

As I understand it, and I could be wrong, business customers get a static IP address by default with Virgin but not with BT, have you tried using DDNS 

1,762 Views
Message 7 of 23

Re: Smarthub 2 and RDP connection

Go to solution

@pfbini 

As @Les-Gibson  has said, your own public IP address will keep changing.

You said "The receiving server has been configured to allow my current IP"

Its quite likely your current IP has changed, so your connection is being rejected.

0 Ratings
Reply
1,745 Views
Message 8 of 23

Re: Smarthub 2 and RDP connection

Go to solution

Obviously the first thing I check is my public IP. I wouldn't bother anybody posting for something as simple as that....

The public IP changes normally if I reset the hub or if the lease expires, but I have checked my IP just before telling the IT manager and did try afterwards.

I'm sure my external IP is right because other IP base services I use are working well.

 

Thanks,

Pierfranco

 

0 Ratings
Reply
1,730 Views
Message 9 of 23

Re: Smarthub 2 and RDP connection

Go to solution

I fail to see if you are originating the request it has anything to do with the BT hub. The hub by default passes ALL outbound traffic.

0 Ratings
Reply
1,723 Views
Message 10 of 23

Re: Smarthub 2 and RDP connection

Go to solution

It might have helped if you had given more information in your original post, I'm not a fan of guessing games